<!DOCTYPE html>
<html lang="en-US" amp="" i-amphtml-layout="" i-amphtml-no-boilerplate="" transformed="self;v=1">
<head><meta charset="UTF-8"><style amp-runtime="" i-amphtml-version="012102130314001">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</style><meta name="viewport" content="width=device-width,initial-scale=1"><meta name="description" content='Flint, MI— Mayor Sheldon Neeley bestowed the City of Flint Ujima Awards to seven "trailblazers" in honor of their work and leadership in the Flint'><meta name="robots" content="index, follow, max-snippet:-1, max-image-preview:large, max-video-preview:-1"><meta property="og:locale" content="en_US"><meta property="og:type" content="article"><meta property="og:title" content="Mayor Neeley honors seven Flint 'trailblazers' for their work in the Black community - Flint Beat"><meta property="og:description" content='Flint, MI— Mayor Sheldon Neeley bestowed the City of Flint Ujima Awards to seven "trailblazers" in honor of their work and leadership in the Flint'><meta property="og:url" content="https://flintbeat.com/mayor-neeley-honors-seven-flint-trailblazers-for-their-work-in-the-black-community/"><meta property="og:site_name" content="Flint Beat"><meta property="article:publisher" content="https://www.facebook.com/flintbeat/"><meta property="article:published_time" content="2021-02-26T12:32:14+00:00"><meta property="article:modified_time" content="2021-02-26T13:55:31+00:00"><meta property="og:image" content="https://i1.wp.com/flintbeat.com/wp-content/uploads/2021/02/0B6A0925.jpg?fit=2500%2C1667&amp;ssl=1"><meta property="og:image:width" content="2500"><meta property="og:image:height" content="1667"><meta name="twitter:card" content="summary_large_image"><meta name="twitter:creator" content="@flintbeat"><meta name="twitter:site" content="@flintbeat"><meta name="twitter:label1" content="Written by"><meta name="twitter:data1" content="Amy Diaz"><meta name="twitter:label2" content="Est. reading time"><meta name="twitter:data2" content="8 minutes"><meta property="fb:pages" content="Flint Beat"><meta property="ia:markup_url" content="https://flintbeat.com/mayor-neeley-honors-seven-flint-trailblazers-for-their-work-in-the-black-community/?ia_markup=1"><meta name="generator" content="Site Kit by Google 1.26.0"><meta name="theme-color" content="#fff"><meta name="apple-mobile-web-app-capable" content="yes"><meta name="mobile-web-app-capable" content="yes"><meta name="apple-touch-fullscreen" content="YES"><meta name="apple-mobile-web-app-title" content="Flint Beat"><meta name="application-name" content="Flint Beat"><meta name="wp-parsely_version" id="wp-parsely_version" content="2.3"><meta name="generator" content="Give v2.9.7"><meta name="generator" content="AMP Plugin v2.0.10; mode=standard"><meta name="msapplication-TileImage" content="https://i1.wp.com/flintbeat.com/wp-content/uploads/2020/10/cropped-OCT20-FlintBeat-SquareLogo.png?fit=270%2C270&amp;ssl=1"><title>Mayor Neeley honors seven Flint 'trailblazers' for their work in the Black community - Flint Beat</title><link rel="preconnect" href="https://cdn.ampproject.org"><link rel="preconnect" href="https://fonts.gstatic.com/" crossorigin=""><link rel="dns-prefetch" href="//cdn.broadstreetads.com"><link rel="dns-prefetch" href="//js.stripe.com"><link rel="dns-prefetch" href="//stats.wp.com"><link rel="dns-prefetch" href="//fonts.googleapis.com"><link rel="dns-prefetch" href="//s.w.org"><link rel="dns-prefetch" href="//c0.wp.com"><link rel="dns-prefetch" href="//i0.wp.com"><link rel="dns-prefetch" href="//i1.wp.com"><link rel="dns-prefetch" href="//i2.wp.com"><link rel="preload" as="script" href="https://cdn.ampproject.org/v0.js"><script type="text/javascript" src="https://cdn.ampproject.org/v0.js" id="amp-runtime-js" async></script><script type="text/javascript" src="https://cdn.ampproject.org/v0/amp-access-0.1.js" id="amp-access-js" async custom-element="amp-access"></script><script src="https://cdn.ampproject.org/v0/amp-ad-0.1.js" async="" custom-element="amp-ad"></script><script src="https://cdn.ampproject.org/v0/amp-analytics-0.1.js" async="" custom-element="amp-analytics"></script><script type="text/javascript" src="https://cdn.ampproject.org/v0/amp-bind-0.1.js" id="amp-bind-js" async custom-element="amp-bind"></script><script src="https://cdn.ampproject.org/v0/amp-form-0.1.js" async="" custom-element="amp-form"></script><script src="https://cdn.ampproject.org/v0/amp-install-serviceworker-0.1.js" async="" custom-element="amp-install-serviceworker"></script><script src="https://cdn.ampproject.org/v0/amp-mustache-0.2.js" async="" custom-template="amp-mustache"></script><script src="https://cdn.ampproject.org/v0/amp-sidebar-0.1.js" async="" custom-element="amp-sidebar"></script><script src="https://cdn.ampproject.org/v0/amp-social-share-0.1.js" async="" custom-element="amp-social-share"></script><link rel="icon" href="https://flintbeat.com/wp-content/uploads/2020/10/cropped-OCT20-FlintBeat-SquareLogo-32x32.png" sizes="32x32"><link rel="icon" href="https://i1.wp.com/flintbeat.com/wp-content/uploads/2020/10/cropped-OCT20-FlintBeat-SquareLogo.png?fit=192%2C192&amp;ssl=1" sizes="192x192"><link crossorigin="anonymous" rel="stylesheet" id="newspack-scott-fonts-css" href="https://fonts.googleapis.com/css?family=Fira+Sans+Condensed%3A400%2C400i%2C600%2C600i&amp;subset=latin%2Clatin-ext&amp;display=swap" type="text/css" media="all"><style amp-custom="">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</style><link rel="profile" href="https://gmpg.org/xfn/11"><!-- This site is optimized with the Yoast SEO plugin v15.9 - https://yoast.com/wordpress/plugins/seo/ --><link rel="canonical" href="https://flintbeat.com/mayor-neeley-honors-seven-flint-trailblazers-for-their-work-in-the-black-community/"><script type="application/ld+json" class="yoast-schema-graph">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</script><!-- / Yoast SEO plugin. --><link rel="alternate" type="application/rss+xml" title="Flint Beat » Feed" href="https://flintbeat.com/feed/"><link rel="alternate" type="application/rss+xml" title="Flint Beat » Comments Feed" href="https://flintbeat.com/comments/feed/"><link rel="alternate" type="application/rss+xml" title="Flint Beat » Mayor Neeley honors seven Flint ‘trailblazers’ for their work in the Black community Comments Feed" href="https://flintbeat.com/mayor-neeley-honors-seven-flint-trailblazers-for-their-work-in-the-black-community/feed/"><link rel="https://api.w.org/" href="https://flintbeat.com/wp-json/"><link rel="alternate" type="application/json" href="https://flintbeat.com/wp-json/wp/v2/posts/14934"><link rel="EditURI" type="application/rsd+xml" title="RSD" href="https://flintbeat.com/xmlrpc.php?rsd"><link rel="wlwmanifest" type="application/wlwmanifest+xml" href="https://flintbeat.com/wp-includes/wlwmanifest.xml"><link rel="shortlink" href="https://flintbeat.com/?p=14934"><!-- Custom Logo: hide header text --><link rel="alternate" type="application/json+oembed" href="https://flintbeat.com/wp-json/oembed/1.0/embed?url=https%3A%2F%2Fflintbeat.com%2Fmayor-neeley-honors-seven-flint-trailblazers-for-their-work-in-the-black-community%2F"><link rel="alternate" type="text/xml+oembed" href="https://flintbeat.com/wp-json/oembed/1.0/embed?url=https%3A%2F%2Fflintbeat.com%2Fmayor-neeley-honors-seven-flint-trailblazers-for-their-work-in-the-black-community%2F&amp;format=xml"><script id="amp-access" type="application/json">
			{"namespace":"popups","authorization":"https:\/\/flintbeat.com\/wp-content\/plugins\/newspack-popups\/includes\/..\/api\/campaigns\/index.php?cid=CLIENT_ID(newspack-cid)&ref=DOCUMENT_REFERRER&popups=[{\"id\":\"id_14611\",\"f\":\"always\",\"utm\":null,\"s\":\"\",\"n\":false,\"d\":false,\"t\":\"i\"}]&settings={\"suppress_newsletter_campaigns\":\"1\",\"suppress_all_newsletter_campaigns_if_one_dismissed\":true,\"suppress_donation_campaigns_if_donor\":false,\"newspack_popups_non_interative_mode\":false,\"newspack_popups_donor_landing_page\":\"\",\"all_segments\":[],\"newspack_popups_active_campaign_group\":false}&visit={\"post_id\":\"14934\",\"categories\":\"2043\",\"is_post\":true}","noPingback":true}		</script><link rel="manifest" href="https://flintbeat.com/wp-json/wp/v2/web-app-manifest"><link rel="apple-touch-startup-image" href="https://i1.wp.com/flintbeat.com/wp-content/uploads/2020/10/cropped-OCT20-FlintBeat-SquareLogo.png?fit=192%2C192&amp;ssl=1"><!-- BEGIN wp-parsely Plugin Version 2.3 --><script type="application/ld+json">
		{"@context":"http:\/\/schema.org","@type":"NewsArticle","mainEntityOfPage":{"@type":"WebPage","@id":"http:\/\/flintbeat.com\/mayor-neeley-honors-seven-flint-trailblazers-for-their-work-in-the-black-community\/"},"headline":"Mayor Neeley honors seven Flint &#8216;trailblazers&#8217; for their work in the Black community","url":"http:\/\/flintbeat.com\/mayor-neeley-honors-seven-flint-trailblazers-for-their-work-in-the-black-community\/","thumbnailUrl":"https:\/\/i1.wp.com\/flintbeat.com\/wp-content\/uploads\/2021\/02\/0B6A0925.jpg?resize=150%2C150&ssl=1","image":{"@type":"ImageObject","url":"https:\/\/i1.wp.com\/flintbeat.com\/wp-content\/uploads\/2021\/02\/0B6A0925.jpg?resize=150%2C150&ssl=1"},"dateCreated":"2021-02-26T12:32:14Z","datePublished":"2021-02-26T12:32:14Z","dateModified":"2021-02-26T12:32:14Z","articleSection":"Community","author":[{"@type":"Person","name":"Amy Diaz"}],"creator":["Amy Diaz"],"publisher":{"@type":"Organization","name":"Flint Beat","logo":"https:\/\/flintbeat.com\/wp-content\/uploads\/2020\/09\/flintbeat-e1599778441406.jpg"},"keywords":["flint community","flint news","flint spotlight"]}
		</script><!-- END wp-parsely Plugin Version 2.3 --><link rel="pingback" href="https://flintbeat.com/xmlrpc.php"><!--noscript--><!--/noscript--><link rel="apple-touch-icon" href="https://i1.wp.com/flintbeat.com/wp-content/uploads/2020/10/cropped-OCT20-FlintBeat-SquareLogo.png?fit=180%2C180&amp;ssl=1"></head>

<body class="post-template-default single single-post postid-14934 single-format-standard wp-custom-logo wp-embed-responsive theme-newspack-theme woocommerce-no-js singular hide-homepage-title hide-site-tagline h-nsub h-db h-ll h-dh h-cta has-tertiary-menu has-featured-image single-featured-image-default has-large-featured-image no-sidebar">
	<amp-sidebar id="mobile-sidebar" layout="nodisplay" side="right" class="mobile-sidebar i-amphtml-layout-nodisplay" hidden="hidden" i-amphtml-layout="nodisplay">
		<button class="mobile-menu-toggle" on="tap:mobile-sidebar.toggle">
			<svg class="svg-icon" width="20" height="20" aria-hidden="true" role="img" xmlns="http://www.w3.org/2000/svg" viewbox="0 0 24 24"><path d="M19 6.41L17.59 5 12 10.59 6.41 5 5 6.41 10.59 12 5 17.59 6.41 19 12 13.41 17.59 19 19 17.59 13.41 12z"></path><path d="M0 0h24v24H0z" fill="none"></path></svg>			Close		</button>

				<nav class="tertiary-menu nav3" aria-label="Tertiary Menu" toolbar-target="tertiary-nav-contain" toolbar="(min-width: 767px)">
			<ul id="menu-tertiary" class="menu"><li id="menu-item-10253" class="menu-highlight menu-item menu-item-type-custom menu-item-object-custom menu-item-10253"><a href="/donate?campaign=7013t000001ZDzCAAW">Donate</a></li>
</ul>		</nav>

<form role="search" method="get" class="search-form" action="https://flintbeat.com/" target="_top">
	<label for="search-form-1">
		<span class="screen-reader-text">Search for:</span>
	</label>
	<input type="search" id="search-form-1" class="search-field" placeholder="Search …" value="" name="s">
	<button type="submit" class="search-submit">
		<svg class="svg-icon" width="28" height="28" aria-hidden="true" role="img" xmlns="http://www.w3.org/2000/svg" viewbox="0 0 24 24"><path d="M15.5 14h-.79l-.28-.27C15.41 12.59 16 11.11 16 9.5 16 5.91 13.09 3 9.5 3S3 5.91 3 9.5 5.91 16 9.5 16c1.61 0 3.09-.59 4.23-1.57l.27.28v.79l5 4.99L20.49 19l-4.99-5zm-6 0C7.01 14 5 11.99 5 9.5S7.01 5 9.5 5 14 7.01 14 9.5 11.99 14 9.5 14z"></path><path d="M0 0h24v24H0z" fill="none"></path></svg>		<span class="screen-reader-text">
			Search		</span>
	</button>
</form>
	<nav class="main-navigation nav1 dd-menu" aria-label="Top Menu" toolbar-target="site-navigation" toolbar="(min-width: 767px)">
		<ul id="menu-main-navigation" class="main-menu"><li id="menu-item-5861" class="menu-item menu-item-type-post_type menu-item-object-post menu-item-has-children menu-item-5861"><a href="https://flintbeat.com/about-us/" aria-haspopup="true" aria-expanded="false">About Us</a><button class="submenu-expand" tabindex="-1"><svg class="svg-icon" width="24" height="24" aria-hidden="true" role="img" focusable="false" xmlns="http://www.w3.org/2000/svg" viewbox="0 0 24 24"><path d="M7.41 8.59L12 13.17l4.59-4.58L18 10l-6 6-6-6 1.41-1.41z"></path><path fill="none" d="M0 0h24v24H0V0z"></path></svg></button>
<ul class="sub-menu">
	<li id="menu-item-4918" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-4918"><a href="https://flintbeat.com/contact-us/">Contact Us</a></li>
	<li id="menu-item-5032" class="menu-item menu-item-type-post_type menu-item-object-post menu-item-5032"><a href="https://flintbeat.com/donor-transparency/">Donor Transparency</a></li>
	<li id="menu-item-5033" class="menu-item menu-item-type-post_type menu-item-object-post menu-item-5033"><a href="https://flintbeat.com/editorial-independence-policy/">Editorial Independence Policy</a></li>
</ul>
</li>
<li id="menu-item-10278" class="menu-item menu-item-type-custom menu-item-object-custom menu-item-10278"><a href="/donate?campaign=7013t000001ZDzCAAW">Donate</a></li>
<li id="menu-item-11725" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-11725"><a href="https://flintbeat.com/2020-elections/">2020 Elections</a></li>
<li id="menu-item-4920" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-4920"><a href="https://flintbeat.com/city-hall-flint-news/">City Hall</a></li>
<li id="menu-item-4924" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-4924"><a href="https://flintbeat.com/education-flint-news/">Education</a></li>
<li id="menu-item-4923" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-4923"><a href="https://flintbeat.com/your-neighborhoods/">Community</a></li>
<li id="menu-item-4917" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-4917"><a href="https://flintbeat.com/arts-culture/">Arts &amp; Culture</a></li>
<li id="menu-item-11666" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-11666"><a href="https://flintbeat.com/covid-19/">COVID-19</a></li>
<li id="menu-item-4922" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-4922"><a href="https://flintbeat.com/flint-water-crisis/">Water Crisis</a></li>
<li id="menu-item-11912" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-11912"><a href="https://flintbeat.com/solutions-journalism/">Solutions Journalism</a></li>
<li id="menu-item-6049" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-6049"><a href="https://flintbeat.com/gun-violence-flints-story/">Gun Violence</a></li>
</ul>	</nav>
	<nav class="secondary-menu nav2 dd-menu" aria-label="Secondary Menu" toolbar-target="secondary-nav-contain" toolbar="(min-width: 767px)">
		<ul id="menu-topbar-navigation" class="secondary-menu"><li id="menu-item-11408" class="menu-item menu-item-type-custom menu-item-object-custom menu-item-11408"><a href="https://checkout.fundjournalism.org/memberform?&amp;org_id=flintbeat&amp;campaign=7013t000001ZDzCAAW">Donate</a></li>
</ul>	</nav>
	<nav class="social-navigation" aria-label="Social Links Menu" toolbar="(min-width: 767px)" toolbar-target="social-nav-contain">
		<ul id="menu-social" class="social-links-menu"><li id="menu-item-10091" class="menu-item menu-item-type-custom menu-item-object-custom menu-item-10091"><a href="https://www.facebook.com/FlintBeat"><span class="screen-reader-text">Facebook</span><svg class="svg-icon" width="26" height="26" aria-hidden="true" role="img" focusable="false" viewbox="0 0 24 24" version="1.1" xmlns="http://www.w3.org/2000/svg" xmlns:xlink="http://www.w3.org/1999/xlink"><path d="M12 2C6.5 2 2 6.5 2 12c0 5 3.7 9.1 8.4 9.9v-7H7.9V12h2.5V9.8c0-2.5 1.5-3.9 3.8-3.9 1.1 0 2.2.2 2.2.2v2.5h-1.3c-1.2 0-1.6.8-1.6 1.6V12h2.8l-.4 2.9h-2.3v7C18.3 21.1 22 17 22 12c0-5.5-4.5-10-10-10z"></path></svg></a></li>
<li id="menu-item-10092" class="menu-item menu-item-type-custom menu-item-object-custom menu-item-10092"><a href="https://twitter.com/@flintbeat"><span class="screen-reader-text">Twitter</span><svg class="svg-icon" width="26" height="26" aria-hidden="true" role="img" focusable="false" viewbox="0 0 24 24" version="1.1" xmlns="http://www.w3.org/2000/svg" xmlns:xlink="http://www.w3.org/1999/xlink"><path d="M22.23,5.924c-0.736,0.326-1.527,0.547-2.357,0.646c0.847-0.508,1.498-1.312,1.804-2.27 c-0.793,0.47-1.671,0.812-2.606,0.996C18.324,4.498,17.257,4,16.077,4c-2.266,0-4.103,1.837-4.103,4.103 c0,0.322,0.036,0.635,0.106,0.935C8.67,8.867,5.647,7.234,3.623,4.751C3.27,5.357,3.067,6.062,3.067,6.814 c0,1.424,0.724,2.679,1.825,3.415c-0.673-0.021-1.305-0.206-1.859-0.513c0,0.017,0,0.034,0,0.052c0,1.988,1.414,3.647,3.292,4.023 c-0.344,0.094-0.707,0.144-1.081,0.144c-0.264,0-0.521-0.026-0.772-0.074c0.522,1.63,2.038,2.816,3.833,2.85 c-1.404,1.1-3.174,1.756-5.096,1.756c-0.331,0-0.658-0.019-0.979-0.057c1.816,1.164,3.973,1.843,6.29,1.843 c7.547,0,11.675-6.252,11.675-11.675c0-0.178-0.004-0.355-0.012-0.531C20.985,7.47,21.68,6.747,22.23,5.924z"></path></svg></a></li>
<li id="menu-item-10093" class="menu-item menu-item-type-custom menu-item-object-custom menu-item-10093"><a href="https://youtube.com/channel/UCoZLyg5TxW5DrqszTDUZFUQ"><span class="screen-reader-text">YouTube</span><svg class="svg-icon" width="26" height="26" aria-hidden="true" role="img" focusable="false" viewbox="0 0 24 24" version="1.1" xmlns="http://www.w3.org/2000/svg" xmlns:xlink="http://www.w3.org/1999/xlink"><path d="M21.8,8.001c0,0-0.195-1.378-0.795-1.985c-0.76-0.797-1.613-0.801-2.004-0.847c-2.799-0.202-6.997-0.202-6.997-0.202 h-0.009c0,0-4.198,0-6.997,0.202C4.608,5.216,3.756,5.22,2.995,6.016C2.395,6.623,2.2,8.001,2.2,8.001S2,9.62,2,11.238v1.517 c0,1.618,0.2,3.237,0.2,3.237s0.195,1.378,0.795,1.985c0.761,0.797,1.76,0.771,2.205,0.855c1.6,0.153,6.8,0.201,6.8,0.201 s4.203-0.006,7.001-0.209c0.391-0.047,1.243-0.051,2.004-0.847c0.6-0.607,0.795-1.985,0.795-1.985s0.2-1.618,0.2-3.237v-1.517 C22,9.62,21.8,8.001,21.8,8.001z M9.935,14.594l-0.001-5.62l5.404,2.82L9.935,14.594z"></path></svg></a></li>
<li id="menu-item-10094" class="menu-item menu-item-type-custom menu-item-object-custom menu-item-10094"><a href="https://instagram.com/FlintBeat"><span class="screen-reader-text">Instagram</span><svg class="svg-icon" width="26" height="26" aria-hidden="true" role="img" focusable="false" viewbox="0 0 24 24" version="1.1" xmlns="http://www.w3.org/2000/svg" xmlns:xlink="http://www.w3.org/1999/xlink"><path d="M12,4.622c2.403,0,2.688,0.009,3.637,0.052c0.877,0.04,1.354,0.187,1.671,0.31c0.42,0.163,0.72,0.358,1.035,0.673 c0.315,0.315,0.51,0.615,0.673,1.035c0.123,0.317,0.27,0.794,0.31,1.671c0.043,0.949,0.052,1.234,0.052,3.637 s-0.009,2.688-0.052,3.637c-0.04,0.877-0.187,1.354-0.31,1.671c-0.163,0.42-0.358,0.72-0.673,1.035 c-0.315,0.315-0.615,0.51-1.035,0.673c-0.317,0.123-0.794,0.27-1.671,0.31c-0.949,0.043-1.233,0.052-3.637,0.052 s-2.688-0.009-3.637-0.052c-0.877-0.04-1.354-0.187-1.671-0.31c-0.42-0.163-0.72-0.358-1.035-0.673 c-0.315-0.315-0.51-0.615-0.673-1.035c-0.123-0.317-0.27-0.794-0.31-1.671C4.631,14.688,4.622,14.403,4.622,12 s0.009-2.688,0.052-3.637c0.04-0.877,0.187-1.354,0.31-1.671c0.163-0.42,0.358-0.72,0.673-1.035 c0.315-0.315,0.615-0.51,1.035-0.673c0.317-0.123,0.794-0.27,1.671-0.31C9.312,4.631,9.597,4.622,12,4.622 M12,3 C9.556,3,9.249,3.01,8.289,3.054C7.331,3.098,6.677,3.25,6.105,3.472C5.513,3.702,5.011,4.01,4.511,4.511 c-0.5,0.5-0.808,1.002-1.038,1.594C3.25,6.677,3.098,7.331,3.054,8.289C3.01,9.249,3,9.556,3,12c0,2.444,0.01,2.751,0.054,3.711 c0.044,0.958,0.196,1.612,0.418,2.185c0.23,0.592,0.538,1.094,1.038,1.594c0.5,0.5,1.002,0.808,1.594,1.038 c0.572,0.222,1.227,0.375,2.185,0.418C9.249,20.99,9.556,21,12,21s2.751-0.01,3.711-0.054c0.958-0.044,1.612-0.196,2.185-0.418 c0.592-0.23,1.094-0.538,1.594-1.038c0.5-0.5,0.808-1.002,1.038-1.594c0.222-0.572,0.375-1.227,0.418-2.185 C20.99,14.751,21,14.444,21,12s-0.01-2.751-0.054-3.711c-0.044-0.958-0.196-1.612-0.418-2.185c-0.23-0.592-0.538-1.094-1.038-1.594 c-0.5-0.5-1.002-0.808-1.594-1.038c-0.572-0.222-1.227-0.375-2.185-0.418C14.751,3.01,14.444,3,12,3L12,3z M12,7.378 c-2.552,0-4.622,2.069-4.622,4.622S9.448,16.622,12,16.622s4.622-2.069,4.622-4.622S14.552,7.378,12,7.378z M12,15 c-1.657,0-3-1.343-3-3s1.343-3,3-3s3,1.343,3,3S13.657,15,12,15z M16.804,6.116c-0.596,0-1.08,0.484-1.08,1.08 s0.484,1.08,1.08,1.08c0.596,0,1.08-0.484,1.08-1.08S17.401,6.116,16.804,6.116z"></path></svg></a></li>
</ul>	</nav><!-- .social-navigation -->

	</amp-sidebar>
	<amp-sidebar id="desktop-sidebar" layout="nodisplay" side="left" class="desktop-sidebar i-amphtml-layout-nodisplay" hidden="hidden" i-amphtml-layout="nodisplay">
		<button class="desktop-menu-toggle" on="tap:desktop-sidebar.toggle">
			<svg class="svg-icon" width="20" height="20" aria-hidden="true" role="img" xmlns="http://www.w3.org/2000/svg" viewbox="0 0 24 24"><path d="M19 6.41L17.59 5 12 10.59 6.41 5 5 6.41 10.59 12 5 17.59 6.41 19 12 13.41 17.59 19 19 17.59 13.41 12z"></path><path d="M0 0h24v24H0z" fill="none"></path></svg>			Close		</button>
	</amp-sidebar>

<div id="page" class="site">
	<a class="skip-link screen-reader-text" href="#content">Skip to content</a>

	<header id="masthead" class="site-header hide-header-search" data-amp-bind-class="searchVisible ? 'show-header-search site-header ' : 'hide-header-search site-header'">

									<div class="top-header-contain desktop-only">
					<div class="wrapper">
						
						<div id="secondary-nav-contain">
													</div>

													<div id="social-nav-contain">
															</div>
						
											</div><!-- .wrapper -->
				</div><!-- .top-header-contain -->
			
			<div class="middle-header-contain">
				<div class="wrapper">
					
					
					
					<div class="site-branding">

	
		<a href="https://flintbeat.com/" class="custom-logo-link" rel="home"><amp-img noloading="" width="567" height="238" src="https://i2.wp.com/flintbeat.com/wp-content/uploads/2020/09/flintbeat-e1599778441406.jpg?fit=567%2C238&amp;ssl=1" class="custom-logo amp-wp-enforced-sizes i-amphtml-layout-intrinsic i-amphtml-layout-size-defined" alt="Flint Beat" srcset="https://i2.wp.com/flintbeat.com/wp-content/uploads/2020/09/flintbeat-e1599778441406.jpg?w=567&amp;ssl=1 567w, https://i2.wp.com/flintbeat.com/wp-content/uploads/2020/09/flintbeat-e1599778441406.jpg?resize=300%2C126&amp;ssl=1 300w" sizes="(max-width: 567px) 100vw, 567px" layout="intrinsic" disable-inline-width="" i-amphtml-layout="intrinsic"><i-amphtml-sizer class="i-amphtml-sizer"><img alt="" aria-hidden="true" class="i-amphtml-intrinsic-sizer" role="presentation" src="data:image/svg+xml;base64,PHN2ZyBoZWlnaHQ9JzIzOCcgd2lkdGg9JzU2NycgeG1sbnM9J2h0dHA6Ly93d3cudzMub3JnLzIwMDAvc3ZnJyB2ZXJzaW9uPScxLjEnLz4="></i-amphtml-sizer><noscript><img width="567" height="238" src="https://i2.wp.com/flintbeat.com/wp-content/uploads/2020/09/flintbeat-e1599778441406.jpg?fit=567%2C238&amp;ssl=1" class="custom-logo" alt="Flint Beat" srcset="https://i2.wp.com/flintbeat.com/wp-content/uploads/2020/09/flintbeat-e1599778441406.jpg?w=567&amp;ssl=1 567w, https://i2.wp.com/flintbeat.com/wp-content/uploads/2020/09/flintbeat-e1599778441406.jpg?resize=300%2C126&amp;ssl=1 300w" sizes="(max-width: 567px) 100vw, 567px"></noscript></amp-img></a>
	<div class="site-identity">
											<p class="site-title"><a href="https://flintbeat.com/" rel="home">Flint Beat</a></p>
					
						<p class="site-description">
					Your Community, Your Voice, Your News				</p>
			</div><!-- .site-identity -->

</div><!-- .site-branding -->

					

					<div class="nav-wrapper desktop-only">
						<div id="tertiary-nav-contain">
													</div><!-- #tertiary-nav-contain -->

											</div><!-- .nav-wrapper -->

					
					<a class="button mb-cta" href="/donate?campaign=7013t000001ZDzCAAW" target="_blank">Donate</a>
											<button class="mobile-menu-toggle" on="tap:mobile-sidebar.toggle">
							<svg class="svg-icon" width="20" height="20" aria-hidden="true" role="img" xmlns="http://www.w3.org/2000/svg" viewbox="0 0 24 24"><path d="M0 0h24v24H0z" fill="none"></path><path d="M3 18h18v-2H3v2zm0-5h18v-2H3v2zm0-7v2h18V6H3z"></path></svg>							<span>Menu</span>
						</button>
					
				</div><!-- .wrapper -->
			</div><!-- .middle-header-contain -->


							<div class="bottom-header-contain desktop-only">
					<div class="wrapper">
						<div id="site-navigation">
													</div>

						
<div class="header-search-contain">
	<button id="search-toggle" on="tap:AMP.setState( { searchVisible: !searchVisible } ), search-form-2.focus" aria-controls="search-menu" data-amp-bind-aria-expanded="searchVisible ? 'true' : 'false'" aria-expanded="false">
		<span class="screen-reader-text" data-amp-bind-text="searchVisible ? 'Close Search' : 'Open Search'">
			Open Search		</span>
		<span class="search-icon"><svg class="svg-icon" width="28" height="28" aria-hidden="true" role="img" xmlns="http://www.w3.org/2000/svg" viewbox="0 0 24 24"><path d="M15.5 14h-.79l-.28-.27C15.41 12.59 16 11.11 16 9.5 16 5.91 13.09 3 9.5 3S3 5.91 3 9.5 5.91 16 9.5 16c1.61 0 3.09-.59 4.23-1.57l.27.28v.79l5 4.99L20.49 19l-4.99-5zm-6 0C7.01 14 5 11.99 5 9.5S7.01 5 9.5 5 14 7.01 14 9.5 11.99 14 9.5 14z"></path><path d="M0 0h24v24H0z" fill="none"></path></svg></span>
		<span class="close-icon"><svg class="svg-icon" width="28" height="28" aria-hidden="true" role="img" xmlns="http://www.w3.org/2000/svg" viewbox="0 0 24 24"><path d="M19 6.41L17.59 5 12 10.59 6.41 5 5 6.41 10.59 12 5 17.59 6.41 19 12 13.41 17.59 19 19 17.59 13.41 12z"></path><path d="M0 0h24v24H0z" fill="none"></path></svg></span>
	</button>
	<div id="header-search" data-amp-bind-aria-expanded="searchVisible ? 'true' : 'false'" aria-expanded="false">
		
<form role="search" method="get" class="search-form" action="https://flintbeat.com/" target="_top">
	<label for="search-form-2">
		<span class="screen-reader-text">Search for:</span>
	</label>
	<input type="search" id="search-form-2" class="search-field" placeholder="Search …" value="" name="s">
	<button type="submit" class="search-submit">
		<svg class="svg-icon" width="28" height="28" aria-hidden="true" role="img" xmlns="http://www.w3.org/2000/svg" viewbox="0 0 24 24"><path d="M15.5 14h-.79l-.28-.27C15.41 12.59 16 11.11 16 9.5 16 5.91 13.09 3 9.5 3S3 5.91 3 9.5 5.91 16 9.5 16c1.61 0 3.09-.59 4.23-1.57l.27.28v.79l5 4.99L20.49 19l-4.99-5zm-6 0C7.01 14 5 11.99 5 9.5S7.01 5 9.5 5 14 7.01 14 9.5 11.99 14 9.5 14z"></path><path d="M0 0h24v24H0z" fill="none"></path></svg>		<span class="screen-reader-text">
			Search		</span>
	</button>
</form>
	</div><!-- #header-search -->
</div><!-- .header-search-contain -->
					</div><!-- .wrapper -->
				</div><!-- .bottom-header-contain -->
					
	</header><!-- #masthead -->

	
	
	<div id="content" class="site-content">

	<section id="primary" class="content-area category-community tag-flint-community tag-flint-news tag-flint-spotlight">
		<main id="main" class="site-main">

			
	<header class="entry-header">
		
	<span class="cat-links"><span class="screen-reader-text">Posted in</span><a href="https://flintbeat.com/category/community/" rel="category tag">Community</a></span>			<h1 class="entry-title ">
			Mayor Neeley honors seven Flint ‘trailblazers’ for their work in the Black community		</h1>
		

	<div class="entry-subhead">
					<div class="entry-meta">
				<span class="author-avatar"><amp-img src="https://flintbeat.com/wp-content/uploads/2020/12/1G9A2276-100x100.jpg" width="80" height="80" alt="Amy Diaz" class="avatar avatar-80 wp-user-avatar wp-user-avatar-80 alignnone photo amp-wp-enforced-sizes i-amphtml-layout-intrinsic i-amphtml-layout-size-defined" layout="intrinsic" i-amphtml-layout="intrinsic"><i-amphtml-sizer class="i-amphtml-sizer"><img alt="" aria-hidden="true" class="i-amphtml-intrinsic-sizer" role="presentation" src="data:image/svg+xml;base64,PHN2ZyBoZWlnaHQ9JzgwJyB3aWR0aD0nODAnIHhtbG5zPSdodHRwOi8vd3d3LnczLm9yZy8yMDAwL3N2ZycgdmVyc2lvbj0nMS4xJy8+"></i-amphtml-sizer><noscript><img src="https://flintbeat.com/wp-content/uploads/2020/12/1G9A2276-100x100.jpg" width="80" height="80" alt="Amy Diaz" class="avatar avatar-80 wp-user-avatar wp-user-avatar-80 alignnone photo"></noscript></amp-img></span>
			<span class="byline">
				<span>by</span>
				<span class="author vcard"><a class="url fn n" href="https://flintbeat.com/author/amy-diaz/">Amy Diaz</a></span> 			</span><!-- .byline -->
		<span class="posted-on"><time class="entry-date published" datetime="2021-02-26T07:32:14-05:00">February 26, 2021</time><time class="updated" datetime="2021-02-26T08:55:31-05:00">February 26, 2021</time></span>			</div><!-- .meta-info -->
				<div class="sharedaddy sd-sharing-enabled"><div class="robots-nocontent sd-block sd-social sd-social-icon-text sd-sharing"><h3 class="sd-title">Share this:</h3><div class="sd-content"><amp-social-share type="twitter" height="32px" width="32px" aria-label="Click to share on Twitter" title="Click to share on Twitter" class="i-amphtml-layout-fixed i-amphtml-layout-size-defined" style="width:32px;height:32px;" i-amphtml-layout="fixed"></amp-social-share><amp-social-share type="facebook" height="32px" width="32px" aria-label="Click to share on Facebook" title="Click to share on Facebook" data-param-app_id="249643311490" class="i-amphtml-layout-fixed i-amphtml-layout-size-defined" style="width:32px;height:32px;" i-amphtml-layout="fixed"></amp-social-share></div></div></div>	</div>
	</header>

	
			<figure class="post-thumbnail">

				<amp-img width="1200" height="800" src="https://i1.wp.com/flintbeat.com/wp-content/uploads/2021/02/0B6A0925.jpg?fit=1200%2C800&amp;ssl=1" class="attachment-newspack-featured-image size-newspack-featured-image wp-post-image amp-wp-enforced-sizes i-amphtml-layout-intrinsic i-amphtml-layout-size-defined" alt="" srcset="https://i1.wp.com/flintbeat.com/wp-content/uploads/2021/02/0B6A0925.jpg?w=2500&amp;ssl=1 2500w, https://i1.wp.com/flintbeat.com/wp-content/uploads/2021/02/0B6A0925.jpg?resize=300%2C200&amp;ssl=1 300w, https://i1.wp.com/flintbeat.com/wp-content/uploads/2021/02/0B6A0925.jpg?resize=2000%2C1334&amp;ssl=1 2000w, https://i1.wp.com/flintbeat.com/wp-content/uploads/2021/02/0B6A0925.jpg?resize=768%2C512&amp;ssl=1 768w, https://i1.wp.com/flintbeat.com/wp-content/uploads/2021/02/0B6A0925.jpg?resize=1536%2C1024&amp;ssl=1 1536w, https://i1.wp.com/flintbeat.com/wp-content/uploads/2021/02/0B6A0925.jpg?resize=2048%2C1366&amp;ssl=1 2048w, https://i1.wp.com/flintbeat.com/wp-content/uploads/2021/02/0B6A0925.jpg?resize=1200%2C800&amp;ssl=1 1200w, https://i1.wp.com/flintbeat.com/wp-content/uploads/2021/02/0B6A0925.jpg?resize=1568%2C1046&amp;ssl=1 1568w, https://i1.wp.com/flintbeat.com/wp-content/uploads/2021/02/0B6A0925.jpg?resize=706%2C471&amp;ssl=1 706w, https://i1.wp.com/flintbeat.com/wp-content/uploads/2021/02/0B6A0925.jpg?w=2340&amp;ssl=1 2340w" sizes="(max-width: 1200px) 100vw, 1200px" layout="intrinsic" disable-inline-width="" i-amphtml-layout="intrinsic"><i-amphtml-sizer class="i-amphtml-sizer"><img alt="" aria-hidden="true" class="i-amphtml-intrinsic-sizer" role="presentation" src="data:image/svg+xml;base64,PHN2ZyBoZWlnaHQ9JzgwMCcgd2lkdGg9JzEyMDAnIHhtbG5zPSdodHRwOi8vd3d3LnczLm9yZy8yMDAwL3N2ZycgdmVyc2lvbj0nMS4xJy8+"></i-amphtml-sizer><noscript><img width="1200" height="800" src="https://i1.wp.com/flintbeat.com/wp-content/uploads/2021/02/0B6A0925.jpg?fit=1200%2C800&amp;ssl=1" class="attachment-newspack-featured-image size-newspack-featured-image wp-post-image" alt="" loading="lazy" srcset="https://i1.wp.com/flintbeat.com/wp-content/uploads/2021/02/0B6A0925.jpg?w=2500&amp;ssl=1 2500w, https://i1.wp.com/flintbeat.com/wp-content/uploads/2021/02/0B6A0925.jpg?resize=300%2C200&amp;ssl=1 300w, https://i1.wp.com/flintbeat.com/wp-content/uploads/2021/02/0B6A0925.jpg?resize=2000%2C1334&amp;ssl=1 2000w, https://i1.wp.com/flintbeat.com/wp-content/uploads/2021/02/0B6A0925.jpg?resize=768%2C512&amp;ssl=1 768w, https://i1.wp.com/flintbeat.com/wp-content/uploads/2021/02/0B6A0925.jpg?resize=1536%2C1024&amp;ssl=1 1536w, https://i1.wp.com/flintbeat.com/wp-content/uploads/2021/02/0B6A0925.jpg?resize=2048%2C1366&amp;ssl=1 2048w, https://i1.wp.com/flintbeat.com/wp-content/uploads/2021/02/0B6A0925.jpg?resize=1200%2C800&amp;ssl=1 1200w, https://i1.wp.com/flintbeat.com/wp-content/uploads/2021/02/0B6A0925.jpg?resize=1568%2C1046&amp;ssl=1 1568w, https://i1.wp.com/flintbeat.com/wp-content/uploads/2021/02/0B6A0925.jpg?resize=706%2C471&amp;ssl=1 706w, https://i1.wp.com/flintbeat.com/wp-content/uploads/2021/02/0B6A0925.jpg?w=2340&amp;ssl=1 2340w" sizes="(max-width: 1200px) 100vw, 1200px"></noscript></amp-img>						<figcaption>Honorees Floyd and Brenda Clack both served as Genesee County Commissioners and State Representatives for the State of Michigan, in addition to being advocates for social justice and youth initiatives. Mayor Sheldon Neeley presented the Mayor Sheldon A. Neeley City of Flint Ujima Awards and  Keys to the City to the honorees in a ceremony at the Flint Development Center. He held a private event for honorees on Feb. 24, 2021. (KT Kanazawich | Flint Beat)</figcaption>
					
			</figure><!-- .post-thumbnail -->

		
				<div class="main-content">

					
<article id="post-14934" class="post-14934 post type-post status-publish format-standard has-post-thumbnail hentry category-community tag-flint-community tag-flint-news tag-flint-spotlight entry">
	<div class="entry-content">

		
		
<p>Flint, MI— Mayor Sheldon Neeley bestowed the City of Flint Ujima Awards to seven “trailblazers” in honor of their work and leadership in the Flint community. </p>



<p>Ujima is the third principle of <a href="https://www.history.com/topics/holidays/kwanzaa-history">Kwanzaa</a> which means “collective work and responsibility.” </p>



<p>“It’s Black History Month, so I thought it would be appropriate to honor the trailblazers of African American descent in our community…so we can reflect on all the great works they have done,” Neeley said during a Feb. 24, 2021 event featuring the seven honorees. “Each of the honorees have played a role in my life and they probably played a role in everybody’s life in this community.” </p>



<p>The award recipients gathered in the auditorium of the former Bunche Elementary School turned Flint Development Center. </p>



<p>For many of them, this private event was the first they’d been to since the pandemic hit. It was worth it, they agreed, to be there and receive this honor. </p><aside class="scaip scaip-1    "></aside>



<figure class="wp-block-image size-large"><amp-img width="780" height="520" src="https://i0.wp.com/flintbeat.com/wp-content/uploads/2021/02/0B6A0669.jpg?resize=780%2C520&amp;ssl=1" alt="" class="wp-image-14944 amp-wp-enforced-sizes i-amphtml-layout-intrinsic i-amphtml-layout-size-defined" srcset="https://i0.wp.com/flintbeat.com/wp-content/uploads/2021/02/0B6A0669.jpg?resize=2000%2C1334&amp;ssl=1 2000w, https://i0.wp.com/flintbeat.com/wp-content/uploads/2021/02/0B6A0669.jpg?resize=300%2C200&amp;ssl=1 300w, https://i0.wp.com/flintbeat.com/wp-content/uploads/2021/02/0B6A0669.jpg?resize=768%2C512&amp;ssl=1 768w, https://i0.wp.com/flintbeat.com/wp-content/uploads/2021/02/0B6A0669.jpg?resize=1536%2C1024&amp;ssl=1 1536w, https://i0.wp.com/flintbeat.com/wp-content/uploads/2021/02/0B6A0669.jpg?resize=2048%2C1366&amp;ssl=1 2048w, https://i0.wp.com/flintbeat.com/wp-content/uploads/2021/02/0B6A0669.jpg?resize=1200%2C800&amp;ssl=1 1200w, https://i0.wp.com/flintbeat.com/wp-content/uploads/2021/02/0B6A0669.jpg?resize=1568%2C1046&amp;ssl=1 1568w, https://i0.wp.com/flintbeat.com/wp-content/uploads/2021/02/0B6A0669.jpg?resize=706%2C471&amp;ssl=1 706w, https://i0.wp.com/flintbeat.com/wp-content/uploads/2021/02/0B6A0669.jpg?w=2340&amp;ssl=1 2340w" sizes="(max-width: 780px) 100vw, 780px" layout="intrinsic" disable-inline-width="" i-amphtml-layout="intrinsic"><i-amphtml-sizer class="i-amphtml-sizer"><img alt="" aria-hidden="true" class="i-amphtml-intrinsic-sizer" role="presentation" src="data:image/svg+xml;base64,PHN2ZyBoZWlnaHQ9JzUyMCcgd2lkdGg9Jzc4MCcgeG1sbnM9J2h0dHA6Ly93d3cudzMub3JnLzIwMDAvc3ZnJyB2ZXJzaW9uPScxLjEnLz4="></i-amphtml-sizer><noscript><img loading="lazy" width="780" height="520" src="https://i0.wp.com/flintbeat.com/wp-content/uploads/2021/02/0B6A0669.jpg?resize=780%2C520&amp;ssl=1" alt="" class="wp-image-14944" srcset="https://i0.wp.com/flintbeat.com/wp-content/uploads/2021/02/0B6A0669.jpg?resize=2000%2C1334&amp;ssl=1 2000w, https://i0.wp.com/flintbeat.com/wp-content/uploads/2021/02/0B6A0669.jpg?resize=300%2C200&amp;ssl=1 300w, https://i0.wp.com/flintbeat.com/wp-content/uploads/2021/02/0B6A0669.jpg?resize=768%2C512&amp;ssl=1 768w, https://i0.wp.com/flintbeat.com/wp-content/uploads/2021/02/0B6A0669.jpg?resize=1536%2C1024&amp;ssl=1 1536w, https://i0.wp.com/flintbeat.com/wp-content/uploads/2021/02/0B6A0669.jpg?resize=2048%2C1366&amp;ssl=1 2048w, https://i0.wp.com/flintbeat.com/wp-content/uploads/2021/02/0B6A0669.jpg?resize=1200%2C800&amp;ssl=1 1200w, https://i0.wp.com/flintbeat.com/wp-content/uploads/2021/02/0B6A0669.jpg?resize=1568%2C1046&amp;ssl=1 1568w, https://i0.wp.com/flintbeat.com/wp-content/uploads/2021/02/0B6A0669.jpg?resize=706%2C471&amp;ssl=1 706w, https://i0.wp.com/flintbeat.com/wp-content/uploads/2021/02/0B6A0669.jpg?w=2340&amp;ssl=1 2340w" sizes="(max-width: 780px) 100vw, 780px"></noscript></amp-img><figcaption>Kathy Burtley accepts an award for her late husband Dr. Nathel Burtley who was Flint’s first Black superintendent of Flint Community Schools. Burtley passed from COVID-19 last year. Mayor Sheldon Neeley honored him with the Mayor Sheldon A. Neeley City of Flint Ujima Award and a Key to the city at a ceremony at the Flint Development Center on Feb. 24, 2021.  (KT Kanazawich | Flint Beat)</figcaption></figure>



<p><strong>Dr. Nathel Burtley </strong></p>



<p>Dr. Burtley was Flint’s first Black superintendent of Flint Community Schools. Neeley said he gave him his first job in the school district in secondary education, which helped him build his confidence.</p>



<p>“We want to make sure that we honor his legacy, and the work that he’s done in education of our community,” Neeley said.</p>



<p>Dr. Burtley died in 2020 from COVID-19. His wife, Kathy, accepted the award on his behalf.</p>



<p>“From the time he got here, he felt like Flint was home and he made it home for him,” she said. “…but he never talked about the hard work he did, because every step that he took, he did it with love and compassion and he loved the Flint community schools and the boys and girls.”</p><aside class="scaip scaip-2    "></aside>



<figure class="wp-block-image size-large"><amp-img width="780" height="520" src="https://i1.wp.com/flintbeat.com/wp-content/uploads/2021/02/0B6A0924.jpg?resize=780%2C520&amp;ssl=1" alt="" class="wp-image-14967 amp-wp-enforced-sizes i-amphtml-layout-intrinsic i-amphtml-layout-size-defined" srcset="https://i1.wp.com/flintbeat.com/wp-content/uploads/2021/02/0B6A0924.jpg?resize=2000%2C1334&amp;ssl=1 2000w, https://i1.wp.com/flintbeat.com/wp-content/uploads/2021/02/0B6A0924.jpg?resize=300%2C200&amp;ssl=1 300w, https://i1.wp.com/flintbeat.com/wp-content/uploads/2021/02/0B6A0924.jpg?resize=768%2C512&amp;ssl=1 768w, https://i1.wp.com/flintbeat.com/wp-content/uploads/2021/02/0B6A0924.jpg?resize=1536%2C1024&amp;ssl=1 1536w, https://i1.wp.com/flintbeat.com/wp-content/uploads/2021/02/0B6A0924.jpg?resize=2048%2C1366&amp;ssl=1 2048w, https://i1.wp.com/flintbeat.com/wp-content/uploads/2021/02/0B6A0924.jpg?resize=1200%2C800&amp;ssl=1 1200w, https://i1.wp.com/flintbeat.com/wp-content/uploads/2021/02/0B6A0924.jpg?resize=1568%2C1046&amp;ssl=1 1568w, https://i1.wp.com/flintbeat.com/wp-content/uploads/2021/02/0B6A0924.jpg?resize=706%2C471&amp;ssl=1 706w, https://i1.wp.com/flintbeat.com/wp-content/uploads/2021/02/0B6A0924.jpg?w=2340&amp;ssl=1 2340w" sizes="(max-width: 780px) 100vw, 780px" layout="intrinsic" disable-inline-width="" i-amphtml-layout="intrinsic"><i-amphtml-sizer class="i-amphtml-sizer"><img alt="" aria-hidden="true" class="i-amphtml-intrinsic-sizer" role="presentation" src="data:image/svg+xml;base64,PHN2ZyBoZWlnaHQ9JzUyMCcgd2lkdGg9Jzc4MCcgeG1sbnM9J2h0dHA6Ly93d3cudzMub3JnLzIwMDAvc3ZnJyB2ZXJzaW9uPScxLjEnLz4="></i-amphtml-sizer><noscript><img loading="lazy" width="780" height="520" src="https://i1.wp.com/flintbeat.com/wp-content/uploads/2021/02/0B6A0924.jpg?resize=780%2C520&amp;ssl=1" alt="" class="wp-image-14967" srcset="https://i1.wp.com/flintbeat.com/wp-content/uploads/2021/02/0B6A0924.jpg?resize=2000%2C1334&amp;ssl=1 2000w, https://i1.wp.com/flintbeat.com/wp-content/uploads/2021/02/0B6A0924.jpg?resize=300%2C200&amp;ssl=1 300w, https://i1.wp.com/flintbeat.com/wp-content/uploads/2021/02/0B6A0924.jpg?resize=768%2C512&amp;ssl=1 768w, https://i1.wp.com/flintbeat.com/wp-content/uploads/2021/02/0B6A0924.jpg?resize=1536%2C1024&amp;ssl=1 1536w, https://i1.wp.com/flintbeat.com/wp-content/uploads/2021/02/0B6A0924.jpg?resize=2048%2C1366&amp;ssl=1 2048w, https://i1.wp.com/flintbeat.com/wp-content/uploads/2021/02/0B6A0924.jpg?resize=1200%2C800&amp;ssl=1 1200w, https://i1.wp.com/flintbeat.com/wp-content/uploads/2021/02/0B6A0924.jpg?resize=1568%2C1046&amp;ssl=1 1568w, https://i1.wp.com/flintbeat.com/wp-content/uploads/2021/02/0B6A0924.jpg?resize=706%2C471&amp;ssl=1 706w, https://i1.wp.com/flintbeat.com/wp-content/uploads/2021/02/0B6A0924.jpg?w=2340&amp;ssl=1 2340w" sizes="(max-width: 780px) 100vw, 780px"></noscript></amp-img><figcaption>Martin Young and his father Dr. Larry Young accept an award on behalf of their late father Ruben Burks. Mayor Sheldon Neeley presented the Mayor Sheldon A. Neeley City of Flint Ujima Awards and  Keys to the City to the honorees in a ceremony at the Flint Development Center. He held a private event for honorees on Feb. 24, 2021. (KT Kanazawich | Flint Beat)</figcaption></figure>



<p><strong>Ruben Burks</strong></p>



<p>Burks was a leader in Flint-Genesee Economic Development, and the first African American International UAW Secretary-Treasurer. </p>



<p>“We talk about collective work, collective bargaining, making sure everybody’s treated fairly across the board,” Neeley said. “…never a better champion that we ever had, Ruben Burks.”</p>



<p>Dr. Larry Young, Burks’ son, accepted the award and said when he thought about his father, he thought about the word ‘legacy.’</p>



<p>“He was the rock of our family. He left a legacy of hard work,” Young said. </p>



<p>Burk’s grandson, Martin Young, was at the event as well. </p>



<p>“My dad spoke on the professional side of his community work, but he was just as diligent as a family man,” he said. “He was a man of few words, but he let u know that he was proud of us, he loved us, and he only accepted excellence from us.”</p>



<figure class="wp-block-image size-large"><amp-img width="780" height="520" src="https://i2.wp.com/flintbeat.com/wp-content/uploads/2021/02/0B6A0737.jpg?resize=780%2C520&amp;ssl=1" alt="" class="wp-image-14954 amp-wp-enforced-sizes i-amphtml-layout-intrinsic i-amphtml-layout-size-defined" srcset="https://i2.wp.com/flintbeat.com/wp-content/uploads/2021/02/0B6A0737.jpg?resize=2000%2C1334&amp;ssl=1 2000w, https://i2.wp.com/flintbeat.com/wp-content/uploads/2021/02/0B6A0737.jpg?resize=300%2C200&amp;ssl=1 300w, https://i2.wp.com/flintbeat.com/wp-content/uploads/2021/02/0B6A0737.jpg?resize=768%2C512&amp;ssl=1 768w, https://i2.wp.com/flintbeat.com/wp-content/uploads/2021/02/0B6A0737.jpg?resize=1536%2C1024&amp;ssl=1 1536w, https://i2.wp.com/flintbeat.com/wp-content/uploads/2021/02/0B6A0737.jpg?resize=2048%2C1366&amp;ssl=1 2048w, https://i2.wp.com/flintbeat.com/wp-content/uploads/2021/02/0B6A0737.jpg?resize=1200%2C800&amp;ssl=1 1200w, https://i2.wp.com/flintbeat.com/wp-content/uploads/2021/02/0B6A0737.jpg?resize=1568%2C1046&amp;ssl=1 1568w, https://i2.wp.com/flintbeat.com/wp-content/uploads/2021/02/0B6A0737.jpg?resize=706%2C471&amp;ssl=1 706w, https://i2.wp.com/flintbeat.com/wp-content/uploads/2021/02/0B6A0737.jpg?w=2340&amp;ssl=1 2340w" sizes="(max-width: 780px) 100vw, 780px" layout="intrinsic" disable-inline-width="" i-amphtml-layout="intrinsic"><i-amphtml-sizer class="i-amphtml-sizer"><img alt="" aria-hidden="true" class="i-amphtml-intrinsic-sizer" role="presentation" src="data:image/svg+xml;base64,PHN2ZyBoZWlnaHQ9JzUyMCcgd2lkdGg9Jzc4MCcgeG1sbnM9J2h0dHA6Ly93d3cudzMub3JnLzIwMDAvc3ZnJyB2ZXJzaW9uPScxLjEnLz4="></i-amphtml-sizer><noscript><img loading="lazy" width="780" height="520" src="https://i2.wp.com/flintbeat.com/wp-content/uploads/2021/02/0B6A0737.jpg?resize=780%2C520&amp;ssl=1" alt="" class="wp-image-14954" srcset="https://i2.wp.com/flintbeat.com/wp-content/uploads/2021/02/0B6A0737.jpg?resize=2000%2C1334&amp;ssl=1 2000w, https://i2.wp.com/flintbeat.com/wp-content/uploads/2021/02/0B6A0737.jpg?resize=300%2C200&amp;ssl=1 300w, https://i2.wp.com/flintbeat.com/wp-content/uploads/2021/02/0B6A0737.jpg?resize=768%2C512&amp;ssl=1 768w, https://i2.wp.com/flintbeat.com/wp-content/uploads/2021/02/0B6A0737.jpg?resize=1536%2C1024&amp;ssl=1 1536w, https://i2.wp.com/flintbeat.com/wp-content/uploads/2021/02/0B6A0737.jpg?resize=2048%2C1366&amp;ssl=1 2048w, https://i2.wp.com/flintbeat.com/wp-content/uploads/2021/02/0B6A0737.jpg?resize=1200%2C800&amp;ssl=1 1200w, https://i2.wp.com/flintbeat.com/wp-content/uploads/2021/02/0B6A0737.jpg?resize=1568%2C1046&amp;ssl=1 1568w, https://i2.wp.com/flintbeat.com/wp-content/uploads/2021/02/0B6A0737.jpg?resize=706%2C471&amp;ssl=1 706w, https://i2.wp.com/flintbeat.com/wp-content/uploads/2021/02/0B6A0737.jpg?w=2340&amp;ssl=1 2340w" sizes="(max-width: 780px) 100vw, 780px"></noscript></amp-img><figcaption>Honoree Cleora Magee previously served as the Executive Director of the City of Flint Human Relations Commission for 11 years, and for 16 years as Community Organizer and Neighborhood Service Center Manager for the Urban Coalition and Flint NIPP. She has been a resident of Flint for 57 years. Mayor Sheldon Neeley presented the Mayor Sheldon A. Neeley City of Flint Ujima Awards and  Keys to the City to the honorees in a ceremony at the Flint Development Center. He held a private event for honorees on Feb. 24, 2021. (KT Kanazawich | Flint Beat)</figcaption></figure>



<p><strong>Cleora Magee</strong></p>



<p>Magee served as the Executive Director of the City of Flint Human Relations Commission (HRC) for 11 years, and 16 years as a Community organizer and Neighborhood Service Center Manager for the Urban Coalition and Flint NIPP. </p>



<p>Neeley called Magee a “gentle soul, a sweet person,” and a “kind-hearted individual.”</p>



<p>Magee said she worked to ensure the HRC was included in the City’s charter and called it “the soul of the city.” </p>



<p>“Not only did it work for human and civil rights, but it also worked for equity…for families who couldn’t get their water on, or didn’t have heat during the winter, and so forth,” she said. “…and so I am just so pleased today to be honored for doing a job that I truly loved.” </p>



<figure class="wp-block-image size-large"><amp-img width="780" height="520" src="https://i2.wp.com/flintbeat.com/wp-content/uploads/2021/02/0B6A0822.jpg?resize=780%2C520&amp;ssl=1" alt="" class="wp-image-14960 amp-wp-enforced-sizes i-amphtml-layout-intrinsic i-amphtml-layout-size-defined" srcset="https://i2.wp.com/flintbeat.com/wp-content/uploads/2021/02/0B6A0822.jpg?resize=2000%2C1334&amp;ssl=1 2000w, https://i2.wp.com/flintbeat.com/wp-content/uploads/2021/02/0B6A0822.jpg?resize=300%2C200&amp;ssl=1 300w, https://i2.wp.com/flintbeat.com/wp-content/uploads/2021/02/0B6A0822.jpg?resize=768%2C512&amp;ssl=1 768w, https://i2.wp.com/flintbeat.com/wp-content/uploads/2021/02/0B6A0822.jpg?resize=1536%2C1024&amp;ssl=1 1536w, https://i2.wp.com/flintbeat.com/wp-content/uploads/2021/02/0B6A0822.jpg?resize=2048%2C1366&amp;ssl=1 2048w, https://i2.wp.com/flintbeat.com/wp-content/uploads/2021/02/0B6A0822.jpg?resize=1200%2C800&amp;ssl=1 1200w, https://i2.wp.com/flintbeat.com/wp-content/uploads/2021/02/0B6A0822.jpg?resize=1568%2C1046&amp;ssl=1 1568w, https://i2.wp.com/flintbeat.com/wp-content/uploads/2021/02/0B6A0822.jpg?resize=706%2C471&amp;ssl=1 706w, https://i2.wp.com/flintbeat.com/wp-content/uploads/2021/02/0B6A0822.jpg?w=2340&amp;ssl=1 2340w" sizes="(max-width: 780px) 100vw, 780px" layout="intrinsic" disable-inline-width="" i-amphtml-layout="intrinsic"><i-amphtml-sizer class="i-amphtml-sizer"><img alt="" aria-hidden="true" class="i-amphtml-intrinsic-sizer" role="presentation" src="data:image/svg+xml;base64,PHN2ZyBoZWlnaHQ9JzUyMCcgd2lkdGg9Jzc4MCcgeG1sbnM9J2h0dHA6Ly93d3cudzMub3JnLzIwMDAvc3ZnJyB2ZXJzaW9uPScxLjEnLz4="></i-amphtml-sizer><noscript><img loading="lazy" width="780" height="520" src="https://i2.wp.com/flintbeat.com/wp-content/uploads/2021/02/0B6A0822.jpg?resize=780%2C520&amp;ssl=1" alt="" class="wp-image-14960" srcset="https://i2.wp.com/flintbeat.com/wp-content/uploads/2021/02/0B6A0822.jpg?resize=2000%2C1334&amp;ssl=1 2000w, https://i2.wp.com/flintbeat.com/wp-content/uploads/2021/02/0B6A0822.jpg?resize=300%2C200&amp;ssl=1 300w, https://i2.wp.com/flintbeat.com/wp-content/uploads/2021/02/0B6A0822.jpg?resize=768%2C512&amp;ssl=1 768w, https://i2.wp.com/flintbeat.com/wp-content/uploads/2021/02/0B6A0822.jpg?resize=1536%2C1024&amp;ssl=1 1536w, https://i2.wp.com/flintbeat.com/wp-content/uploads/2021/02/0B6A0822.jpg?resize=2048%2C1366&amp;ssl=1 2048w, https://i2.wp.com/flintbeat.com/wp-content/uploads/2021/02/0B6A0822.jpg?resize=1200%2C800&amp;ssl=1 1200w, https://i2.wp.com/flintbeat.com/wp-content/uploads/2021/02/0B6A0822.jpg?resize=1568%2C1046&amp;ssl=1 1568w, https://i2.wp.com/flintbeat.com/wp-content/uploads/2021/02/0B6A0822.jpg?resize=706%2C471&amp;ssl=1 706w, https://i2.wp.com/flintbeat.com/wp-content/uploads/2021/02/0B6A0822.jpg?w=2340&amp;ssl=1 2340w" sizes="(max-width: 780px) 100vw, 780px"></noscript></amp-img><figcaption>Honoree Norm Bryant, founder and former owner of the historic Bryant’s Barber Shop. Bryant also founded the Greater Flint African American Sports Hall of Fame for black athletes from the Flint area. Mayor Sheldon Neeley presented the Mayor Sheldon A. Neeley City of Flint Ujima Awards and  Keys to the City to the honorees in a ceremony at the Flint Development Center. He held a private event for honorees on Feb. 24, 2021. (KT Kanazawich | Flint Beat)</figcaption></figure>



<p><strong>Norm Bryant</strong></p>



<p>Bryant is the founder and former owner of the historic Bryant’s Barber Shop, and founder of the Greater Flint African American Sports Hall of Game.</p>


<aside>					<amp-analytics class="i-amphtml-layout-fixed i-amphtml-layout-size-defined" style="width:1px;height:1px;" i-amphtml-layout="fixed">
			<script type="application/json">
				{"requests":{"event":"https:\/\/flintbeat.com\/wp-content\/plugins\/newspack-popups\/includes\/..\/api\/campaigns\/index.php"},"triggers":{"trackPageview":{"on":"visible","request":"event","visibilitySpec":{"selector":"#lightbox1106304366","visiblePercentageMin":90,"totalTimeMin":500,"continuousTimeMin":200},"extraUrlParams":{"popup_id":"id_14611","cid":"CLIENT_ID(newspack-cid)"}},"formSubmitSuccess":{"on":"amp-form-submit-success","request":"event","selector":"#lightbox1106304366 .wp-block-jetpack-mailchimp form","extraUrlParams":{"popup_id":"id_14611","cid":"CLIENT_ID(newspack-cid)","mailing_list_status":"subscribed","email":"$[formFields[email]}"}}}}			</script>
		</amp-analytics>
					<amp-layout amp-access="popups.id_14611" amp-access-hide class=" newspack-inline-popup    amp-wp-85c1a93 i-amphtml-layout-container" role="button" tabindex="0" id="lightbox1106304366" data-amp-original-style="background-color:#FFFFFF;color:#000" i-amphtml-layout="container">
												
<div class="wp-block-group newspack-pattern subscribe__style-3 has-primary-background-color has-background"><div class="wp-block-group__inner-container">
<div class="wp-block-columns are-vertically-aligned-center">
<div class="wp-block-column is-vertically-aligned-center">
<h2>Never miss a story. Sign up for our weekly news roundup!</h2>



<p></p>
</div>



<div class="wp-block-column is-vertically-aligned-center"><amp-layout id="wp-block-jetpack-mailchimp-60396329a20f8" class="i-amphtml-layout-container" i-amphtml-layout="container">
	<div class="wp-block-jetpack-mailchimp" data-blog-id="182260188">
		<div class="components-placeholder">
			<form aria-describedby="wp-block-jetpack-mailchimp_consent-text" action-xhr="https://public-api.wordpress.com/rest/v1.1/sites/182260188/email_follow/amp/subscribe/" method="post" id="mailchimp_form" target="_top" on="submit-success:AMP.setState( { mailing_list_status: 'subscribed', mailing_list_email: event.response.email } )">
				<p>
					<input aria-label="Enter your email" placeholder="Enter your email" required title="Enter your email" type="email" name="email">
				</p>
												
<div class="wp-block-jetpack-button wp-block-button"><button class="wp-block-button__link" style="" data-id-attr="mailchimp-button-block-3" id="mailchimp-button-block-3" type="submit">Never miss a story! Sign up now!</button></div>
				<p id="wp-block-jetpack-mailchimp_consent-text">
					We’re working to cover Flint. We empower and inform the community we serve through impactful journalism.				</p>

				
					<div submit-success>
						<template type="amp-mustache">
							<div class="wp-block-jetpack-mailchimp_notification wp-block-jetpack-mailchimp_success wp-block-jetpack-mailchimp__is-amp">
								Success! You're on the list.							</div>
						</template>
					</div>
					<div submit-error>
						<template type="amp-mustache">
							<div class="wp-block-jetpack-mailchimp_notification wp-block-jetpack-mailchimp_error wp-block-jetpack-mailchimp__is-amp">
								Whoops! There was an error and we couldn't process your subscription. Please reload the page and try again.							</div>
						</template>
					</div>
					<div submitting>
						<template type="amp-mustache">
							<div class="wp-block-jetpack-mailchimp_notification wp-block-jetpack-mailchimp_processing wp-block-jetpack-mailchimp__is-amp" role="status">
								Processing…							</div>
						</template>
					</div>

				
			</form>
					</div>
	</div>
	</amp-layout></div>
</div>
</div></div>
											<form class="popup-not-interested-form popup-action-form align-center" method="POST" action-xhr="https://flintbeat.com/wp-content/plugins/newspack-popups/includes/../api/campaigns/index.php" target="_top">
									<input name="popup_id" type="hidden" value="id_14611">
		<input name="cid" type="hidden" value="CLIENT_ID(newspack-cid)" data-amp-replace="CLIENT_ID">
		<input name="mailing_list_status" type="hidden" data-amp-bind-value="mailing_list_status">
		<input name="is_newsletter_popup" type="hidden" value="">
								<input name="suppress_forever" type="hidden" value="1">
						<button on="tap:lightbox1106304366.hide" aria-label="" data-amp-original-style="background-color:#FFFFFF;color:#000" class="amp-wp-85c1a93">I'm not interested</button>
					</form>
							</amp-layout>
		</aside>

<p>When he accepted his honor Bryant said he was at a loss for words because he would “rather be doing something for someone else, rather than having someone else do something” for him. </p>



<p>He also spoke about the importance of educating people about Black history.</p>



<p>“We need to teach Black history in every school in the city. You know, the NAACP used to fight to get jobs, fight to get positions…we need to start fighting,” Bryant said. “Because history is what we’re made of, and it’s always been said that people shall perish for their lack of knowledge…Flint is rich in history.”</p>



<figure class="wp-block-image size-large"><amp-img width="780" height="520" src="https://i0.wp.com/flintbeat.com/wp-content/uploads/2021/02/0B6A0907.jpg?resize=780%2C520&amp;ssl=1" alt="" class="wp-image-14966 amp-wp-enforced-sizes i-amphtml-layout-intrinsic i-amphtml-layout-size-defined" srcset="https://i0.wp.com/flintbeat.com/wp-content/uploads/2021/02/0B6A0907.jpg?resize=2000%2C1334&amp;ssl=1 2000w, https://i0.wp.com/flintbeat.com/wp-content/uploads/2021/02/0B6A0907.jpg?resize=300%2C200&amp;ssl=1 300w, https://i0.wp.com/flintbeat.com/wp-content/uploads/2021/02/0B6A0907.jpg?resize=768%2C512&amp;ssl=1 768w, https://i0.wp.com/flintbeat.com/wp-content/uploads/2021/02/0B6A0907.jpg?resize=1536%2C1024&amp;ssl=1 1536w, https://i0.wp.com/flintbeat.com/wp-content/uploads/2021/02/0B6A0907.jpg?resize=2048%2C1366&amp;ssl=1 2048w, https://i0.wp.com/flintbeat.com/wp-content/uploads/2021/02/0B6A0907.jpg?resize=1200%2C800&amp;ssl=1 1200w, https://i0.wp.com/flintbeat.com/wp-content/uploads/2021/02/0B6A0907.jpg?resize=1568%2C1046&amp;ssl=1 1568w, https://i0.wp.com/flintbeat.com/wp-content/uploads/2021/02/0B6A0907.jpg?resize=706%2C471&amp;ssl=1 706w, https://i0.wp.com/flintbeat.com/wp-content/uploads/2021/02/0B6A0907.jpg?w=2340&amp;ssl=1 2340w" sizes="(max-width: 780px) 100vw, 780px" layout="intrinsic" disable-inline-width="" i-amphtml-layout="intrinsic"><i-amphtml-sizer class="i-amphtml-sizer"><img alt="" aria-hidden="true" class="i-amphtml-intrinsic-sizer" role="presentation" src="data:image/svg+xml;base64,PHN2ZyBoZWlnaHQ9JzUyMCcgd2lkdGg9Jzc4MCcgeG1sbnM9J2h0dHA6Ly93d3cudzMub3JnLzIwMDAvc3ZnJyB2ZXJzaW9uPScxLjEnLz4="></i-amphtml-sizer><noscript><img loading="lazy" width="780" height="520" src="https://i0.wp.com/flintbeat.com/wp-content/uploads/2021/02/0B6A0907.jpg?resize=780%2C520&amp;ssl=1" alt="" class="wp-image-14966" srcset="https://i0.wp.com/flintbeat.com/wp-content/uploads/2021/02/0B6A0907.jpg?resize=2000%2C1334&amp;ssl=1 2000w, https://i0.wp.com/flintbeat.com/wp-content/uploads/2021/02/0B6A0907.jpg?resize=300%2C200&amp;ssl=1 300w, https://i0.wp.com/flintbeat.com/wp-content/uploads/2021/02/0B6A0907.jpg?resize=768%2C512&amp;ssl=1 768w, https://i0.wp.com/flintbeat.com/wp-content/uploads/2021/02/0B6A0907.jpg?resize=1536%2C1024&amp;ssl=1 1536w, https://i0.wp.com/flintbeat.com/wp-content/uploads/2021/02/0B6A0907.jpg?resize=2048%2C1366&amp;ssl=1 2048w, https://i0.wp.com/flintbeat.com/wp-content/uploads/2021/02/0B6A0907.jpg?resize=1200%2C800&amp;ssl=1 1200w, https://i0.wp.com/flintbeat.com/wp-content/uploads/2021/02/0B6A0907.jpg?resize=1568%2C1046&amp;ssl=1 1568w, https://i0.wp.com/flintbeat.com/wp-content/uploads/2021/02/0B6A0907.jpg?resize=706%2C471&amp;ssl=1 706w, https://i0.wp.com/flintbeat.com/wp-content/uploads/2021/02/0B6A0907.jpg?w=2340&amp;ssl=1 2340w" sizes="(max-width: 780px) 100vw, 780px"></noscript></amp-img><figcaption>Honorees Floyd and Brenda Clack both served as Genesee County Commissioners and State Representatives for the State of Michigan, in addition to being advocates for social justice and youth initiatives. Mayor Sheldon Neeley presented the Mayor Sheldon A. Neeley City of Flint Ujima Awards and  Keys to the City to the honorees in a ceremony at the Flint Development Center. He held a private event for honorees on Feb. 24, 2021. (KT Kanazawich | Flint Beat)</figcaption></figure>



<p><strong>Floyd and Brenda Clack</strong></p>



<p>Neeley introduced these two as Flint’s power couple. </p>



<p>“We know Jay Z has Beyonce. We know Barack has Michelle. And we also know that Floyd has Brenda,” Neeley said. </p>



<p>Floyd and Brenda Clack both served as Genesee County Commissioners and State Representatives for Michigan. They also worked in education and social justice advocacy. </p>



<p>Brenda Clack spoke about how she helped write the program and select the book to be used to teach Black history in schools, and the bills she sponsored to ban smoking indoors, and help foster children. </p>



<p>Floyd Clack shared the story of how he and Brenda met, with a little help from her on the details. </p>



<p>They both said they were so thankful to have ended up in Flint, although it wasn’t the plan for either of them originally. </p>



<p>“This city has afforded Floyd and I so many positive things,” Brenda said.</p>



<figure class="wp-block-image size-large"><amp-img width="780" height="520" src="https://i0.wp.com/flintbeat.com/wp-content/uploads/2021/02/0B6A0950.jpg?resize=780%2C520&amp;ssl=1" alt="" class="wp-image-14970 amp-wp-enforced-sizes i-amphtml-layout-intrinsic i-amphtml-layout-size-defined" srcset="https://i0.wp.com/flintbeat.com/wp-content/uploads/2021/02/0B6A0950.jpg?resize=2000%2C1334&amp;ssl=1 2000w, https://i0.wp.com/flintbeat.com/wp-content/uploads/2021/02/0B6A0950.jpg?resize=300%2C200&amp;ssl=1 300w, https://i0.wp.com/flintbeat.com/wp-content/uploads/2021/02/0B6A0950.jpg?resize=768%2C512&amp;ssl=1 768w, https://i0.wp.com/flintbeat.com/wp-content/uploads/2021/02/0B6A0950.jpg?resize=1536%2C1024&amp;ssl=1 1536w, https://i0.wp.com/flintbeat.com/wp-content/uploads/2021/02/0B6A0950.jpg?resize=2048%2C1366&amp;ssl=1 2048w, https://i0.wp.com/flintbeat.com/wp-content/uploads/2021/02/0B6A0950.jpg?resize=1200%2C800&amp;ssl=1 1200w, https://i0.wp.com/flintbeat.com/wp-content/uploads/2021/02/0B6A0950.jpg?resize=1568%2C1046&amp;ssl=1 1568w, https://i0.wp.com/flintbeat.com/wp-content/uploads/2021/02/0B6A0950.jpg?resize=706%2C471&amp;ssl=1 706w, https://i0.wp.com/flintbeat.com/wp-content/uploads/2021/02/0B6A0950.jpg?w=2340&amp;ssl=1 2340w" sizes="(max-width: 780px) 100vw, 780px" layout="intrinsic" disable-inline-width="" i-amphtml-layout="intrinsic"><i-amphtml-sizer class="i-amphtml-sizer"><img alt="" aria-hidden="true" class="i-amphtml-intrinsic-sizer" role="presentation" src="data:image/svg+xml;base64,PHN2ZyBoZWlnaHQ9JzUyMCcgd2lkdGg9Jzc4MCcgeG1sbnM9J2h0dHA6Ly93d3cudzMub3JnLzIwMDAvc3ZnJyB2ZXJzaW9uPScxLjEnLz4="></i-amphtml-sizer><noscript><img loading="lazy" width="780" height="520" src="https://i0.wp.com/flintbeat.com/wp-content/uploads/2021/02/0B6A0950.jpg?resize=780%2C520&amp;ssl=1" alt="" class="wp-image-14970" srcset="https://i0.wp.com/flintbeat.com/wp-content/uploads/2021/02/0B6A0950.jpg?resize=2000%2C1334&amp;ssl=1 2000w, https://i0.wp.com/flintbeat.com/wp-content/uploads/2021/02/0B6A0950.jpg?resize=300%2C200&amp;ssl=1 300w, https://i0.wp.com/flintbeat.com/wp-content/uploads/2021/02/0B6A0950.jpg?resize=768%2C512&amp;ssl=1 768w, https://i0.wp.com/flintbeat.com/wp-content/uploads/2021/02/0B6A0950.jpg?resize=1536%2C1024&amp;ssl=1 1536w, https://i0.wp.com/flintbeat.com/wp-content/uploads/2021/02/0B6A0950.jpg?resize=2048%2C1366&amp;ssl=1 2048w, https://i0.wp.com/flintbeat.com/wp-content/uploads/2021/02/0B6A0950.jpg?resize=1200%2C800&amp;ssl=1 1200w, https://i0.wp.com/flintbeat.com/wp-content/uploads/2021/02/0B6A0950.jpg?resize=1568%2C1046&amp;ssl=1 1568w, https://i0.wp.com/flintbeat.com/wp-content/uploads/2021/02/0B6A0950.jpg?resize=706%2C471&amp;ssl=1 706w, https://i0.wp.com/flintbeat.com/wp-content/uploads/2021/02/0B6A0950.jpg?w=2340&amp;ssl=1 2340w" sizes="(max-width: 780px) 100vw, 780px"></noscript></amp-img><figcaption>Honoree Joe Davis was Flint’s first African American City of Flint firefighter. He worked from 1961-1975 as the only black firefighter in the department.  Mayor Sheldon Neeley presented the Mayor Sheldon A. Neeley City of Flint Ujima Awards and  Keys to the City to the honorees in a ceremony at the Flint Development Center. He held a private event for honorees on Feb. 24, 2021. (KT Kanazawich | Flint Beat)</figcaption></figure>



<p><strong>Joe Davis</strong></p>



<p>Davis was Flint’s first African-American firefighter for the City of Flint Fire Department, and served as the only Black firefighter in the department for 15 years, from 1961 to 1975. </p>



<p>Neeley said when he called Davis to ask if he would accept this honor, he found out that he was actually very close friends with Neeley’s late grandfather. </p>



<p>Davis, 88, spoke about his life growing up in poverty, serving in the military, moving to Flint, working for General Motors and eventually working at the fire department. </p>



<p>“With me, as a child growing up in the slums…I didn’t know anything about segregation, because my parents never talked about it,” Davis said. “…I didn’t realize that I was being discriminated against, it was just a way of life until later on I began to learn these situations that existed.” </p>



<p>He spoke about the fact that discrimination and racism still exists today, with “bad apples” in America who try to perpetuate these things and halt progress. To eradicate these problems, Davis said Black history needs to be taught 365 days a year. </p>



<p>“Regardless of how bleak the future may appear to be, stand together with the good apples from that bushel. The bad ones, pay them no attention,” he said. “You see all of the trust and prejudice that I had to endure, it didn’t change my appetite for apples. I still like apples. I just toss the bad ones out.” </p>



<p> </p>

<nav class="jp-relatedposts-i2" data-layout="grid"><h3 class="jp-relatedposts-headline"><em>Related</em></h3><div class="jp-related-posts-i2__row" data-post-count="3"><ul id="related-posts-item-60396329a3b11" aria-labelledby="related-posts-item-60396329a3b11-label" class="jp-related-posts-i2__post" role="menuitem"><li class="jp-related-posts-i2__post-link"><a id="related-posts-item-60396329a3b11-label" href="https://flintbeat.com/will-more-local-cops-decrease-flints-violent-crime/">Will more local cops decrease Flint's violent crime?</a></li><li class="jp-related-posts-i2__post-img-link"><a href="https://flintbeat.com/will-more-local-cops-decrease-flints-violent-crime/"><amp-img src="https://i1.wp.com/flintbeat.com/wp-content/uploads/2017/04/Police-Service-Center-58a.jpg?fit=1200%2C730&amp;ssl=1&amp;resize=350%2C200" width="350" alt="" height="200" class="amp-wp-enforced-sizes i-amphtml-layout-intrinsic i-amphtml-layout-size-defined" layout="intrinsic" i-amphtml-layout="intrinsic"><i-amphtml-sizer class="i-amphtml-sizer"><img alt="" aria-hidden="true" class="i-amphtml-intrinsic-sizer" role="presentation" src="data:image/svg+xml;base64,PHN2ZyBoZWlnaHQ9JzIwMCcgd2lkdGg9JzM1MCcgeG1sbnM9J2h0dHA6Ly93d3cudzMub3JnLzIwMDAvc3ZnJyB2ZXJzaW9uPScxLjEnLz4="></i-amphtml-sizer><noscript><img src="https://i1.wp.com/flintbeat.com/wp-content/uploads/2017/04/Police-Service-Center-58a.jpg?fit=1200%2C730&amp;ssl=1&amp;resize=350%2C200" width="350" alt="" height="200" class=""></noscript></amp-img></a></li><li class="jp-related-posts-i2__post-date">August 20, 2020</li><li class="jp-related-posts-i2__post-context">In "Solutions Journalism"</li></ul><ul id="related-posts-item-60396329a3b47" aria-labelledby="related-posts-item-60396329a3b47-label" class="jp-related-posts-i2__post" role="menuitem"><li class="jp-related-posts-i2__post-link"><a id="related-posts-item-60396329a3b47-label" href="https://flintbeat.com/community-gathers-virtually-to-talk-justice-and-policing-in-flint/">Community gathers virtually to talk justice and policing in Flint</a></li><li class="jp-related-posts-i2__post-img-link"><a href="https://flintbeat.com/community-gathers-virtually-to-talk-justice-and-policing-in-flint/"><amp-img src="https://i0.wp.com/flintbeat.com/wp-content/uploads/2021/02/0B6A3152.jpg?fit=1200%2C800&amp;ssl=1&amp;resize=350%2C200" width="350" alt="" height="200" class="amp-wp-enforced-sizes i-amphtml-layout-intrinsic i-amphtml-layout-size-defined" layout="intrinsic" i-amphtml-layout="intrinsic"><i-amphtml-sizer class="i-amphtml-sizer"><img alt="" aria-hidden="true" class="i-amphtml-intrinsic-sizer" role="presentation" src="data:image/svg+xml;base64,PHN2ZyBoZWlnaHQ9JzIwMCcgd2lkdGg9JzM1MCcgeG1sbnM9J2h0dHA6Ly93d3cudzMub3JnLzIwMDAvc3ZnJyB2ZXJzaW9uPScxLjEnLz4="></i-amphtml-sizer><noscript><img src="https://i0.wp.com/flintbeat.com/wp-content/uploads/2021/02/0B6A3152.jpg?fit=1200%2C800&amp;ssl=1&amp;resize=350%2C200" width="350" alt="" height="200" class=""></noscript></amp-img></a></li><li class="jp-related-posts-i2__post-date">February 18, 2021</li><li class="jp-related-posts-i2__post-context">In "Community"</li></ul><ul id="related-posts-item-60396329a3b68" aria-labelledby="related-posts-item-60396329a3b68-label" class="jp-related-posts-i2__post" role="menuitem"><li class="jp-related-posts-i2__post-link"><a id="related-posts-item-60396329a3b68-label" href="https://flintbeat.com/mayor-neeley-appoints-terence-green-to-be-new-flint-police-chief/">Mayor Neeley appoints Terence Green to be new Flint Police Chief</a></li><li class="jp-related-posts-i2__post-img-link"><a href="https://flintbeat.com/mayor-neeley-appoints-terence-green-to-be-new-flint-police-chief/"><amp-img src="https://i2.wp.com/flintbeat.com/wp-content/uploads/2020/08/1G9A1099.jpg?fit=1200%2C800&amp;ssl=1&amp;resize=350%2C200" width="350" alt="" height="200" class="amp-wp-enforced-sizes i-amphtml-layout-intrinsic i-amphtml-layout-size-defined" layout="intrinsic" i-amphtml-layout="intrinsic"><i-amphtml-sizer class="i-amphtml-sizer"><img alt="" aria-hidden="true" class="i-amphtml-intrinsic-sizer" role="presentation" src="data:image/svg+xml;base64,PHN2ZyBoZWlnaHQ9JzIwMCcgd2lkdGg9JzM1MCcgeG1sbnM9J2h0dHA6Ly93d3cudzMub3JnLzIwMDAvc3ZnJyB2ZXJzaW9uPScxLjEnLz4="></i-amphtml-sizer><noscript><img src="https://i2.wp.com/flintbeat.com/wp-content/uploads/2020/08/1G9A1099.jpg?fit=1200%2C800&amp;ssl=1&amp;resize=350%2C200" width="350" alt="" height="200" class=""></noscript></amp-img></a></li><li class="jp-related-posts-i2__post-date">August 12, 2020</li><li class="jp-related-posts-i2__post-context">In "Flint City Hall"</li></ul></div></nav>	</div><!-- .entry-content -->

	<footer class="entry-footer">
		<span class="tags-links"><span>Tagged: </span><a href="https://flintbeat.com/tag/flint-community/" rel="tag">Flint Community</a><span class="sep">, </span><a href="https://flintbeat.com/tag/flint-news/" rel="tag">Flint News</a><span class="sep">, </span><a href="https://flintbeat.com/tag/flint-spotlight/" rel="tag">Flint Spotlight</a></span>	</footer><!-- .entry-footer -->

	
			<div class="author-bio">
				<amp-img src="https://flintbeat.com/wp-content/uploads/2020/12/1G9A2276-100x100.jpg" width="80" height="80" alt="Amy Diaz" class="avatar avatar-80 wp-user-avatar wp-user-avatar-80 alignnone photo amp-wp-enforced-sizes i-amphtml-layout-intrinsic i-amphtml-layout-size-defined" layout="intrinsic" i-amphtml-layout="intrinsic"><i-amphtml-sizer class="i-amphtml-sizer"><img alt="" aria-hidden="true" class="i-amphtml-intrinsic-sizer" role="presentation" src="data:image/svg+xml;base64,PHN2ZyBoZWlnaHQ9JzgwJyB3aWR0aD0nODAnIHhtbG5zPSdodHRwOi8vd3d3LnczLm9yZy8yMDAwL3N2ZycgdmVyc2lvbj0nMS4xJy8+"></i-amphtml-sizer><noscript><img src="https://flintbeat.com/wp-content/uploads/2020/12/1G9A2276-100x100.jpg" width="80" height="80" alt="Amy Diaz" class="avatar avatar-80 wp-user-avatar wp-user-avatar-80 alignnone photo"></noscript></amp-img>
				<div class="author-bio-text">
					<div class="author-bio-header">
						<div>
							<h2 class="accent-header">
								Amy Diaz								<span></span>
							</h2>

							
						</div>
					</div><!-- .author-bio-header -->

											<p>
							Amy Diaz is a journalist hailing from St. Petersburg, FL. She has written for multiple local newspapers in her hometown before becoming a full-time reporter for Flint Beat. When she’s not writing you...							<a class="author-link" href="https://flintbeat.com/author/amy-diaz/" rel="author">
							More by Amy Diaz							</a>
						</p>
					
				</div><!-- .author-bio-text -->

			</div><!-- .author-bio -->
		
</article><!-- #post-${ID} -->

<div id="comments" class="comments-area">
	<div class="comments-title-wrap no-responses">
		<h2 class="comments-title">
		Leave a comment		</h2><!-- .comments-title -->
			</div><!-- .comments-title-flex -->
			<div id="respond" class="comment-respond">
		<h3 id="reply-title" class="comment-reply-title"> <small><a id="cancel-comment-reply-link" href="/mayor-neeley-honors-seven-flint-trailblazers-for-their-work-in-the-black-community/#respond" hidden data-amp-bind-hidden='commentform_post_14934.values.comment_parent == "0"' on='tap:AMP.setState( {"commentform_post_14934":{"replyToName":"","values":{"comment_parent":"0"}}} )'>Cancel reply</a></small></h3><form method="post" id="commentform" class="comment-form" novalidate action-xhr="https://flintbeat.com/wp-comments-post.php?_wp_amp_action_xhr_converted=1" target="_top" on='submit:AMP.setState( { "commentform_post_14934": { submitting: true } } );submit-error:AMP.setState( { "commentform_post_14934": { submitting: false } } );submit-success:AMP.setState( { commentform_post_14934: {"values":{"submit":"Post Comment","comment_post_ID":"14934","comment_parent":"0","akismet_comment_nonce":"d2a021a860","ak_js":"92","comment":"","ak_hp_textarea":""},"submitting":false,"replyToName":""} } )'><amp-state id="commentform_post_14934" class="i-amphtml-layout-container" i-amphtml-layout="container"><script type="application/json">{"values":{"author":"","email":"","url":"","submit":"Post Comment","comment_post_ID":"14934","comment_parent":"0","akismet_comment_nonce":"d2a021a860","ak_js":"92","comment":"","ak_hp_textarea":""},"submitting":false,"replyToName":""}</script></amp-state><p class="comment-notes"><span id="email-notes">Your email address will not be published.</span> Required fields are marked <span class="required">*</span></p><p class="comment-form-comment"><label for="comment">Comment</label> <textarea id="comment" name="comment" cols="45" rows="5" maxlength="65525" required="required" data-amp-bind-disabled="commentform_post_14934.submitting" data-amp-bind-text="commentform_post_14934.values.comment" on='change:AMP.setState( { commentform_post_14934: { values: { "comment": event.value } } } )'></textarea></p><p class="comment-form-author"><label for="author">Name <span class="required">*</span></label> <input id="author" name="author" type="text" value="" size="30" maxlength="245" required="required" data-amp-bind-disabled="commentform_post_14934.submitting" data-amp-bind-value="commentform_post_14934.values.author" on='change:AMP.setState( { commentform_post_14934: { values: { "author": event.value } } } )'></p>
<p class="comment-form-email"><label for="email">Email <span class="required">*</span></label> <input id="email" name="email" type="email" value="" size="30" maxlength="100" aria-describedby="email-notes" required="required" data-amp-bind-disabled="commentform_post_14934.submitting" data-amp-bind-value="commentform_post_14934.values.email" on='change:AMP.setState( { commentform_post_14934: { values: { "email": event.value } } } )'></p>
<p class="comment-form-url"><label for="url">Website</label> <input id="url" name="url" type="url" value="" size="30" maxlength="200" data-amp-bind-disabled="commentform_post_14934.submitting" data-amp-bind-value="commentform_post_14934.values.url" on='change:AMP.setState( { commentform_post_14934: { values: { "url": event.value } } } )'></p>
<p class="form-submit"><input name="submit" type="submit" id="submit" class="submit" value="Post Comment" data-amp-bind-disabled="commentform_post_14934.submitting" data-amp-bind-value="commentform_post_14934.values.submit" on='change:AMP.setState( { commentform_post_14934: { values: { "submit": event.value } } } )'> <input type="hidden" name="comment_post_ID" value="14934" id="comment_post_ID" data-amp-bind-disabled="commentform_post_14934.submitting" data-amp-bind-value="commentform_post_14934.values.comment_post_ID" on='change:AMP.setState( { commentform_post_14934: { values: { "comment_post_ID": event.value } } } )'>
<input type="hidden" name="comment_parent" id="comment_parent" value="0" data-amp-bind-disabled="commentform_post_14934.submitting" data-amp-bind-value="commentform_post_14934.values.comment_parent" on='change:AMP.setState( { commentform_post_14934: { values: { "comment_parent": event.value } } } )'>
</p><p data-amp-original-style="display: none;" class="amp-wp-224b51a"><input type="hidden" id="akismet_comment_nonce" name="akismet_comment_nonce" value="d2a021a860" data-amp-bind-disabled="commentform_post_14934.submitting" data-amp-bind-value="commentform_post_14934.values.akismet_comment_nonce" on='change:AMP.setState( { commentform_post_14934: { values: { "akismet_comment_nonce": event.value } } } )'></p><input type="hidden" id="ak_js" name="ak_js" value="92" data-amp-bind-disabled="commentform_post_14934.submitting" data-amp-bind-value="commentform_post_14934.values.ak_js" on='change:AMP.setState( { commentform_post_14934: { values: { "ak_js": event.value } } } )'><textarea name="ak_hp_textarea" cols="45" rows="8" maxlength="100" data-amp-bind-disabled="commentform_post_14934.submitting" data-amp-bind-text="commentform_post_14934.values.ak_hp_textarea" on='change:AMP.setState( { commentform_post_14934: { values: { "ak_hp_textarea": event.value } } } )' data-amp-original-style="display: none !important;" class="amp-wp-3e2e7c3"></textarea>				<div class="amp-wp-default-form-message" submit-error=""><template type="amp-mustache"><p class="{{#redirecting}}amp-wp-form-redirecting{{/redirecting}}">{{#message}}{{{message}}}{{/message}}{{^message}}Your submission failed. <small>The server responded with {{status_text}} (code {{status_code}}). Please contact the developer of this form processor to improve this message. <a href="https://amp-wp.org/?p=5463" target="_blank">Learn More</a></small>{{/message}}</p></template></div><div class="amp-wp-default-form-message" submit-success=""><template type="amp-mustache"><p class="{{#redirecting}}amp-wp-form-redirecting{{/redirecting}}">{{#message}}{{{message}}}{{/message}}{{^message}}It appears your submission was successful. <small>Even though the server responded OK, it is possible the submission was not processed. Please contact the developer of this form processor to improve this message. <a href="https://amp-wp.org/?p=5463" target="_blank">Learn More</a></small>{{/message}}</p></template></div><div class="amp-wp-default-form-message" submitting=""><template type="amp-mustache"><p>Submitting…</p></template></div></form>	</div><!-- #respond -->
	</div><!-- #comments -->
				</div><!-- .main-content -->

			
		</main><!-- #main -->
	</section><!-- #primary -->


	
	</div><!-- #content -->

	<footer id="colophon" class="site-footer">

					<div class="footer-branding">
		<div class="wrapper">
			
		<a href="https://flintbeat.com/" class="custom-logo-link" rel="home"><amp-img noloading="" width="567" height="238" src="https://i2.wp.com/flintbeat.com/wp-content/uploads/2020/09/flintbeat-e1599778441406.jpg?fit=567%2C238&amp;ssl=1" class="custom-logo amp-wp-enforced-sizes i-amphtml-layout-intrinsic i-amphtml-layout-size-defined" alt="Flint Beat" srcset="https://i2.wp.com/flintbeat.com/wp-content/uploads/2020/09/flintbeat-e1599778441406.jpg?w=567&amp;ssl=1 567w, https://i2.wp.com/flintbeat.com/wp-content/uploads/2020/09/flintbeat-e1599778441406.jpg?resize=300%2C126&amp;ssl=1 300w" sizes="(max-width: 567px) 100vw, 567px" layout="intrinsic" disable-inline-width="" i-amphtml-layout="intrinsic"><i-amphtml-sizer class="i-amphtml-sizer"><img alt="" aria-hidden="true" class="i-amphtml-intrinsic-sizer" role="presentation" src="data:image/svg+xml;base64,PHN2ZyBoZWlnaHQ9JzIzOCcgd2lkdGg9JzU2NycgeG1sbnM9J2h0dHA6Ly93d3cudzMub3JnLzIwMDAvc3ZnJyB2ZXJzaW9uPScxLjEnLz4="></i-amphtml-sizer><noscript><img width="567" height="238" src="https://i2.wp.com/flintbeat.com/wp-content/uploads/2020/09/flintbeat-e1599778441406.jpg?fit=567%2C238&amp;ssl=1" class="custom-logo" alt="Flint Beat" srcset="https://i2.wp.com/flintbeat.com/wp-content/uploads/2020/09/flintbeat-e1599778441406.jpg?w=567&amp;ssl=1 567w, https://i2.wp.com/flintbeat.com/wp-content/uploads/2020/09/flintbeat-e1599778441406.jpg?resize=300%2C126&amp;ssl=1 300w" sizes="(max-width: 567px) 100vw, 567px"></noscript></amp-img></a>	<nav class="social-navigation" aria-label="Social Links Menu">
		<ul id="menu-social-1" class="social-links-menu"><li class="menu-item menu-item-type-custom menu-item-object-custom menu-item-10091"><a href="https://www.facebook.com/FlintBeat"><span class="screen-reader-text">Facebook</span><svg class="svg-icon" width="26" height="26" aria-hidden="true" role="img" focusable="false" viewbox="0 0 24 24" version="1.1" xmlns="http://www.w3.org/2000/svg" xmlns:xlink="http://www.w3.org/1999/xlink"><path d="M12 2C6.5 2 2 6.5 2 12c0 5 3.7 9.1 8.4 9.9v-7H7.9V12h2.5V9.8c0-2.5 1.5-3.9 3.8-3.9 1.1 0 2.2.2 2.2.2v2.5h-1.3c-1.2 0-1.6.8-1.6 1.6V12h2.8l-.4 2.9h-2.3v7C18.3 21.1 22 17 22 12c0-5.5-4.5-10-10-10z"></path></svg></a></li>
<li class="menu-item menu-item-type-custom menu-item-object-custom menu-item-10092"><a href="https://twitter.com/@flintbeat"><span class="screen-reader-text">Twitter</span><svg class="svg-icon" width="26" height="26" aria-hidden="true" role="img" focusable="false" viewbox="0 0 24 24" version="1.1" xmlns="http://www.w3.org/2000/svg" xmlns:xlink="http://www.w3.org/1999/xlink"><path d="M22.23,5.924c-0.736,0.326-1.527,0.547-2.357,0.646c0.847-0.508,1.498-1.312,1.804-2.27 c-0.793,0.47-1.671,0.812-2.606,0.996C18.324,4.498,17.257,4,16.077,4c-2.266,0-4.103,1.837-4.103,4.103 c0,0.322,0.036,0.635,0.106,0.935C8.67,8.867,5.647,7.234,3.623,4.751C3.27,5.357,3.067,6.062,3.067,6.814 c0,1.424,0.724,2.679,1.825,3.415c-0.673-0.021-1.305-0.206-1.859-0.513c0,0.017,0,0.034,0,0.052c0,1.988,1.414,3.647,3.292,4.023 c-0.344,0.094-0.707,0.144-1.081,0.144c-0.264,0-0.521-0.026-0.772-0.074c0.522,1.63,2.038,2.816,3.833,2.85 c-1.404,1.1-3.174,1.756-5.096,1.756c-0.331,0-0.658-0.019-0.979-0.057c1.816,1.164,3.973,1.843,6.29,1.843 c7.547,0,11.675-6.252,11.675-11.675c0-0.178-0.004-0.355-0.012-0.531C20.985,7.47,21.68,6.747,22.23,5.924z"></path></svg></a></li>
<li class="menu-item menu-item-type-custom menu-item-object-custom menu-item-10093"><a href="https://youtube.com/channel/UCoZLyg5TxW5DrqszTDUZFUQ"><span class="screen-reader-text">YouTube</span><svg class="svg-icon" width="26" height="26" aria-hidden="true" role="img" focusable="false" viewbox="0 0 24 24" version="1.1" xmlns="http://www.w3.org/2000/svg" xmlns:xlink="http://www.w3.org/1999/xlink"><path d="M21.8,8.001c0,0-0.195-1.378-0.795-1.985c-0.76-0.797-1.613-0.801-2.004-0.847c-2.799-0.202-6.997-0.202-6.997-0.202 h-0.009c0,0-4.198,0-6.997,0.202C4.608,5.216,3.756,5.22,2.995,6.016C2.395,6.623,2.2,8.001,2.2,8.001S2,9.62,2,11.238v1.517 c0,1.618,0.2,3.237,0.2,3.237s0.195,1.378,0.795,1.985c0.761,0.797,1.76,0.771,2.205,0.855c1.6,0.153,6.8,0.201,6.8,0.201 s4.203-0.006,7.001-0.209c0.391-0.047,1.243-0.051,2.004-0.847c0.6-0.607,0.795-1.985,0.795-1.985s0.2-1.618,0.2-3.237v-1.517 C22,9.62,21.8,8.001,21.8,8.001z M9.935,14.594l-0.001-5.62l5.404,2.82L9.935,14.594z"></path></svg></a></li>
<li class="menu-item menu-item-type-custom menu-item-object-custom menu-item-10094"><a href="https://instagram.com/FlintBeat"><span class="screen-reader-text">Instagram</span><svg class="svg-icon" width="26" height="26" aria-hidden="true" role="img" focusable="false" viewbox="0 0 24 24" version="1.1" xmlns="http://www.w3.org/2000/svg" xmlns:xlink="http://www.w3.org/1999/xlink"><path d="M12,4.622c2.403,0,2.688,0.009,3.637,0.052c0.877,0.04,1.354,0.187,1.671,0.31c0.42,0.163,0.72,0.358,1.035,0.673 c0.315,0.315,0.51,0.615,0.673,1.035c0.123,0.317,0.27,0.794,0.31,1.671c0.043,0.949,0.052,1.234,0.052,3.637 s-0.009,2.688-0.052,3.637c-0.04,0.877-0.187,1.354-0.31,1.671c-0.163,0.42-0.358,0.72-0.673,1.035 c-0.315,0.315-0.615,0.51-1.035,0.673c-0.317,0.123-0.794,0.27-1.671,0.31c-0.949,0.043-1.233,0.052-3.637,0.052 s-2.688-0.009-3.637-0.052c-0.877-0.04-1.354-0.187-1.671-0.31c-0.42-0.163-0.72-0.358-1.035-0.673 c-0.315-0.315-0.51-0.615-0.673-1.035c-0.123-0.317-0.27-0.794-0.31-1.671C4.631,14.688,4.622,14.403,4.622,12 s0.009-2.688,0.052-3.637c0.04-0.877,0.187-1.354,0.31-1.671c0.163-0.42,0.358-0.72,0.673-1.035 c0.315-0.315,0.615-0.51,1.035-0.673c0.317-0.123,0.794-0.27,1.671-0.31C9.312,4.631,9.597,4.622,12,4.622 M12,3 C9.556,3,9.249,3.01,8.289,3.054C7.331,3.098,6.677,3.25,6.105,3.472C5.513,3.702,5.011,4.01,4.511,4.511 c-0.5,0.5-0.808,1.002-1.038,1.594C3.25,6.677,3.098,7.331,3.054,8.289C3.01,9.249,3,9.556,3,12c0,2.444,0.01,2.751,0.054,3.711 c0.044,0.958,0.196,1.612,0.418,2.185c0.23,0.592,0.538,1.094,1.038,1.594c0.5,0.5,1.002,0.808,1.594,1.038 c0.572,0.222,1.227,0.375,2.185,0.418C9.249,20.99,9.556,21,12,21s2.751-0.01,3.711-0.054c0.958-0.044,1.612-0.196,2.185-0.418 c0.592-0.23,1.094-0.538,1.594-1.038c0.5-0.5,0.808-1.002,1.038-1.594c0.222-0.572,0.375-1.227,0.418-2.185 C20.99,14.751,21,14.444,21,12s-0.01-2.751-0.054-3.711c-0.044-0.958-0.196-1.612-0.418-2.185c-0.23-0.592-0.538-1.094-1.038-1.594 c-0.5-0.5-1.002-0.808-1.594-1.038c-0.572-0.222-1.227-0.375-2.185-0.418C14.751,3.01,14.444,3,12,3L12,3z M12,7.378 c-2.552,0-4.622,2.069-4.622,4.622S9.448,16.622,12,16.622s4.622-2.069,4.622-4.622S14.552,7.378,12,7.378z M12,15 c-1.657,0-3-1.343-3-3s1.343-3,3-3s3,1.343,3,3S13.657,15,12,15z M16.804,6.116c-0.596,0-1.08,0.484-1.08,1.08 s0.484,1.08,1.08,1.08c0.596,0,1.08-0.484,1.08-1.08S17.401,6.116,16.804,6.116z"></path></svg></a></li>
</ul>	</nav><!-- .social-navigation -->
		</div><!-- .wrapper -->
	</div><!-- .footer-branding -->
		
	<aside class="widget-area footer-widgets" role="complementary" aria-label="Footer">
		<div class="wrapper">
			<section id="bs_zones-11" class="widget bs_zones"><div><amp-ad type="broadstreetads" layout="responsive" width="728" height="90" data-network="4974" data-zone="81607" data-keywords="not_home_page,not_landing_page,is_article_page,community,mayor-neeley-honors-seven-flint-trailblazers-for-their-work-in-the-black-community,post" class="i-amphtml-layout-responsive i-amphtml-layout-size-defined" i-amphtml-layout="responsive"><i-amphtml-sizer style="display:block;padding-top:12.3626%;"></i-amphtml-sizer></amp-ad></div></section>		</div><!-- .wrapper -->
	</aside><!-- .widget-area -->


		<div class="site-info">

			
			<div class="wrapper site-info-contain">
													<span class="copyright">© 2021 Flint Beat.</span>
				
				<a href="https://newspack.pub/" class="imprint">
					Proudly powered by Newspack by Automattic				</a>

							</div><!-- .wrapper -->
		</div><!-- .site-info -->
	</footer><!-- #colophon -->

</div><!-- #page -->



			<amp-analytics type="gtag" config="https://flintbeat.com/wp-content/plugins/newspack-popups/includes/../api/segmentation/index.php?client_id=CLIENT_ID(newspack-cid)&amp;post_id=14934&amp;custom_dimensions=[]&amp;custom_dimensions_existing_values=[]" class="i-amphtml-layout-fixed i-amphtml-layout-size-defined" style="width:1px;height:1px;" i-amphtml-layout="fixed"></amp-analytics>
		

<!-- START Parse.ly Include: Standard -->



<!-- END Parse.ly Include: Standard -->
		<amp-install-serviceworker src="https://flintbeat.com/wp.serviceworker" data-iframe-src="https://flintbeat.com/?amp_install_service_worker_iframe=1" layout="nodisplay" class="i-amphtml-layout-nodisplay" hidden="hidden" i-amphtml-layout="nodisplay">
		</amp-install-serviceworker>
		<amp-analytics type="gtag" data-credentials="include" class="i-amphtml-layout-fixed i-amphtml-layout-size-defined" style="width:1px;height:1px;" i-amphtml-layout="fixed"><script type="application/json">{"optoutElementId":"__gaOptOutExtension","vars":{"gtag_id":"UA-88263457-1","config":{"UA-88263457-1":{"groups":"default","linker":[],"send_page_view":false}}},"triggers":{"socialShareClickedFacebook":{"request":"event","on":"click","vars":{"event_name":"social share","event_label":"facebook","event_category":"NTG social","non_interaction":false},"selector":"amp-social-share[type=\"facebook\"]"},"socialShareClickedTwitter":{"request":"event","on":"click","vars":{"event_name":"social share","event_label":"twitter","event_category":"NTG social","non_interaction":false},"selector":"amp-social-share[type=\"twitter\"]"},"socialShareClickedWhatsApp":{"request":"event","on":"click","vars":{"event_name":"social share","event_label":"whatsapp","event_category":"NTG social","non_interaction":false},"selector":"amp-social-share[type=\"whatsapp\"]"},"socialShareClickedLinkedIn":{"request":"event","on":"click","vars":{"event_name":"social share","event_label":"linkedin","event_category":"NTG social","non_interaction":false},"selector":"amp-social-share[type=\"linkedin\"]"},"articleRead25":{"request":"event","on":"scroll","vars":{"event_name":"25%","event_label":"Mayor Neeley honors seven Flint &#8216;trailblazers&#8217; for their work in the Black community","event_category":"NTG article milestone","non_interaction":true,"value":25},"event_value":25,"non_interaction":true,"scrollSpec":{"verticalBoundaries":[25]}},"articleRead50":{"request":"event","on":"scroll","vars":{"event_name":"50%","event_label":"Mayor Neeley honors seven Flint &#8216;trailblazers&#8217; for their work in the Black community","event_category":"NTG article milestone","non_interaction":true,"value":50},"event_value":50,"non_interaction":true,"scrollSpec":{"verticalBoundaries":[50]}},"articleRead100":{"request":"event","on":"scroll","vars":{"event_name":"100%","event_label":"Mayor Neeley honors seven Flint &#8216;trailblazers&#8217; for their work in the Black community","event_category":"NTG article milestone","non_interaction":true,"value":100},"event_value":100,"non_interaction":true,"scrollSpec":{"verticalBoundaries":[100]}},"popupPageLoaded-14611":{"request":"event","on":"ini-load","vars":{"event_name":"Load","event_label":"Newspack Announcement: Never miss a story! (14611)","event_category":"Newspack Announcement","non_interaction":true},"selector":"#lightbox1106304366","non_interaction":true},"popupSeen-14611":{"request":"event","on":"visible","vars":{"event_name":"Seen","event_label":"Newspack Announcement: Never miss a story! (14611)","event_category":"Newspack Announcement","non_interaction":true},"selector":"#lightbox1106304366","non_interaction":true,"visibilitySpec":{"totalTimeMin":500}},"popupFormSubmitSuccess-14611":{"request":"event","on":"amp-form-submit-success","vars":{"event_name":"Form Submission","event_label":"Newspack Announcement: Never miss a story! (14611)","event_category":"Newspack Announcement","non_interaction":false},"selector":"#lightbox1106304366 form:not(.popup-action-form)"},"popupNotInterested-14611":{"request":"event","on":"amp-form-submit-success","vars":{"event_name":"Permanent Dismissal","event_label":"Newspack Announcement: Never miss a story! (14611)","event_category":"Newspack Announcement","non_interaction":true},"selector":"#lightbox1106304366 form.popup-not-interested-form","non_interaction":true},"newsletterSignup-wp-block-jetpack-mailchimp-60396329a20f8":{"request":"event","on":"amp-form-submit-success","vars":{"event_name":"newsletter signup","event_label":"success","event_category":"NTG newsletter","non_interaction":false},"selector":"#wp-block-jetpack-mailchimp-60396329a20f8 form","visibilitySpec":{"totalTimeMin":500}},"newsletterImpression-wp-block-jetpack-mailchimp-60396329a20f8":{"request":"event","on":"visible","vars":{"event_name":"newsletter modal impression 1","event_label":"Mayor Neeley honors seven Flint &#8216;trailblazers&#8217; for their work in the Black community","event_category":"NTG newsletter","non_interaction":true},"selector":"#wp-block-jetpack-mailchimp-60396329a20f8","non_interaction":true,"visibilitySpec":{"totalTimeMin":500}},"addComment":{"request":"event","on":"amp-form-submit-success","vars":{"event_name":"comment added","event_label":"Mayor Neeley honors seven Flint &#8216;trailblazers&#8217; for their work in the Black community","event_category":"NTG user","non_interaction":false},"selector":"#commentform"}}}</script></amp-analytics><amp-analytics id="parsely" type="parsely" class="i-amphtml-layout-fixed i-amphtml-layout-size-defined" style="width:1px;height:1px;" i-amphtml-layout="fixed"><script type="application/json">{"vars":{"apikey":"flintbeat.com"}}</script></amp-analytics>	
	

















			<amp-analytics class="i-amphtml-layout-fixed i-amphtml-layout-size-defined" style="width:1px;height:1px;" i-amphtml-layout="fixed">
				<script type="application/json">
					{"linkers":{"enabled":true,"ref_newspack_cid":{"ids":{"cid":"CLIENT_ID(newspack-cid)"}}},"cookies":{"enabled":true,"newspack-cid":{"value":"LINKER_PARAM(ref_newspack_cid, cid)"}}}				</script>
			</amp-analytics>
			<amp-pixel src="https://pixel.wp.com/g.gif?v=ext&amp;j=1%3A9.4.1&amp;blog=182260188&amp;post=14934&amp;tz=-5&amp;srv=flintbeat.com&amp;host=flintbeat.com&amp;rand=RANDOM&amp;ref=DOCUMENT_REFERRER" class="i-amphtml-layout-fixed i-amphtml-layout-size-defined" style="width:1px;height:1px;" i-amphtml-layout="fixed"></amp-pixel>
	

</body></html>
<!--
	generated in 0.776 seconds
	159572 bytes batcached for 300 seconds
-->
